Author Topic: Visio Services page linked to Sharepoint list data only updates with client?  (Read 2936 times)

0 Members and 1 Guest are viewing this topic.

rlntel

  • Newbie
  • *
  • Posts: 9
Hi,

I've successfully linked a diagram to SharePoint list data and published the diagram to a SharePoint library. SharePoint Services is running.

If I change the list data, I expect (even after a significant wait) that the diagram in the SP library linked to the list data will update.

It does not.

I've waited sometimes over an hour with no luck.

The only way I can get the diagram to update is to open it in Visio client refresh the data and then save. If either of those steps is missed, the diagram on SharePoint fails to update.

Any thoughts?

Thanks in advance.

cliff50

  • Full Member
  • ***
  • Posts: 159
Hi,

I've successfully linked a diagram to SharePoint list data and published the diagram to a SharePoint library. SharePoint Services is running.

If I change the list data, I expect (even after a significant wait) that the diagram in the SP library linked to the list data will update.

It does not.

I've waited sometimes over an hour with no luck.

The only way I can get the diagram to update is to open it in Visio client refresh the data and then save. If either of those steps is missed, the diagram on SharePoint fails to update.

Any thoughts?

Thanks in advance.

I am thinking the Visio diagram with the linked shapes, will always need to be data refreshed ....   to accomplish this you may need to program the "refresh data" action  from the Visio document opened event. 

rlntel

  • Newbie
  • *
  • Posts: 9
On the .vdw page on SharePoint, a "Refresh Data" button is visible. Nothing happens when I click it. Is the "refresh action" different somehow?

FYI...when I click the browser refresh button, still nothing happens.

The only thing that works is returning to the Visio client, clicking "Refresh All" on the Data tab, then going back to the .vdw in SharePoint and clicking either the refresh button or refreshing the browser.

Nikolay

  • Hero Member
  • *****
  • Posts: 741
    • UnmanagedVisio
I would say this means your SharePoint Visio Services are not configured properly.
Most probably it is a security issue (account under which SharePoint VisioServices serviced application runs is not allowed to access your data list, or secure store is not configured)

If you have admin access to the SharePoint, you should login to the SharePoint as admin and configure your VisioServices properly (see the links below).
If you don't have access you could ask your admin/support to do that for you.
There is nothing you can do in Visio to resolve that.

About the refresh time - if you want an instant refresh, you could disable caching (set it it zero), again in the SharePoint VisioServices settings.

Microsoft has has written a lab guide how to configure things in SharePoint, "Configure Visio Services"
https://technet.microsoft.com/en-us/library/jj900483.aspx

You may be especially interested in "Configure Visio Services data refresh using an external connection":
https://technet.microsoft.com/en-us/library/jj900487.aspx
« Last Edit: August 30, 2015, 05:33:25 AM by Nikolay »

rlntel

  • Newbie
  • *
  • Posts: 9
Awesome! Thank you!