Author Topic: Visio no longer opens drawings ==>crashes with no msgs  (Read 2136 times)

0 Members and 1 Guest are viewing this topic.

Paul Herber

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3301
    • Paul Herber's website
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #15 on: March 22, 2022, 02:20:16 PM »
Yeah but, that's the desktop version, probably not &^%£ed around with improved as much as the online version.
Electronic and Electrical engineering, business and software stencils and applications for Visio -

https://www.paulherber.co.uk/

vojo

  • Hero Member
  • *****
  • Posts: 1675
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #16 on: March 22, 2022, 03:41:18 PM »
I am running on 64bit windows 10 pro....19043.1503....16GB of memory....476GB of Storage (330GB free).
(nothing changed between Febuary and now RE OS, memory, storage). 

I did try to remove 64bit visio and install 32 bit visio, install failed because I guess 64 bit OS does not like 32 bit apps
(that seemed odd to me...but I decided not to become some sort of windows OS guru).

In plan 2, there is an option to download to desktop / only view in the cloud....I did that because security concerns around possibility of MS looking at work product....and....ability to work offline

I tried opening from within visio...no luck
All drawings that were at most 4MB, opened fine....all drawings 6MB or larger just kick out...so estimated around 5 MB limit

I did try using drawing.io to open...they opened but
1) it blew up 8MB drawing to 48MB drawing
2) drawing IO processes shapes to get visuals...but it does not create detailed shapesheet...just an image shapesheet
3) drawing.io ==> export ==> VSDX really gives a collection of images ...1 per shape

Since no messages when this happens, loading bar never moves...my guess is there is some timeout involved.
(could write a custom "drawing opener" with VBA...but not convinced it would be productive...I would not know how to make a "verbose" open macro that gave any sort of status codes or messages)

Again...thx to paul for help me out.

vojo

  • Hero Member
  • *****
  • Posts: 1675
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #17 on: March 22, 2022, 09:53:13 PM »
So all, I have to eat my words.

Basically, some of the previous posts questioned my 5MB statement.  So I started to look at error codes.
That got me to refresh the OS
(Generally well thought out tool in the security panel....but BTW says you keep your data...but just blows away your apps that are needed to use your data).

I did the windows 10 refresh.  Lo and behold, after 5 hours of struggling, got most of the apps reinstalled.

So the moment of truth:  I used visio to open that big file...it now opens.

Thx for the education guys ;-)

so going back thru things, the only thing I added in the last month was PyCharm IDE.
not sure this caused the problem but not reinstall.

vojo

  • Hero Member
  • *****
  • Posts: 1675
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #18 on: March 22, 2022, 10:55:18 PM »
well...it came back....I give up

wapperdude

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4449
  • Ideas Visio-lized into solutions
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #19 on: March 23, 2022, 10:00:15 AM »
I feel your pain and frustration.  That OS refresh scenario is worse than going to the dentist!  Then, after all of that, to have the problem solved, and then re-appear.  All that time and effort.  Not a process you want to ever do again.

Between the time that it was working and when the problem returned,
   > I presume no other apps were added.
   > was the PC powered on/off one or more times?
   > was Visio the last app installed?
   > can you disable some of the Startup apps that automatic begin when Windows launches?

Hardware related:
    > presumably, you have plenty of RAM
    > the system uses "harddrive" to augment RAM by doing active read/writes for running program
    > might there be regions with bad / damaged bits?

It may be, that you have to uninstall all the apps one more time.  Then run hard drive optimizer to check for bad sectors.  i vaguely recall needing to clean out some "caches" too.   Follow this with reinstall of Office followed by Visio.  Then, do several PC power on cycles to verify everything is working.  Presumably, Visio is working fine at this point.  If not, perhaps one more Windows refresh. 

Also, are your app data files/documents backed up in separate location?  It maybe there is corruption or virus in one of them???  Just asking to cover all possible bases.

So, in the subsequent reinstalling of apps, just do one at a time.  Each time followed by multiple power on/off cycles and verification of Visio.  Hopefully, this traps the offending step.  It will probably extend that 5 hours. 

I merely offer the above as a possible, incremental methodology. 
Visio 2019 Pro

vojo

  • Hero Member
  • *****
  • Posts: 1675
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #20 on: March 23, 2022, 01:03:19 PM »
Appreciate the words of encouragement!!

I kept at and I think I am on to something.  So in essence, after taking 5 hours to rebuild my system last night, I was pretty discouraged.   Slept some (still tired).  So in between meetings, tried a few things.   Finally, I said "what about DRAM allocation?" So went to system settings...notice the page cache size was a min = 1GB and max = 3GB.   Figured lets just
take a shot in the dark   min = 4GB  max = 8GB.

Guess what:  I have successfully opened the file 10 times with no problem!!!!

Lets hope it continues to work....but at least if some windows service changes it so that visio no longer open large files, I
know where something that changes visio behavior is.

Not declaring victory yet...but keeping finger crossed. 
(surprised windows does not adjust...something like "if cache is 80% filled, maybe should grow cache by 1.2X on next boot"
or "if RAM is X, then allocation 0.5X to cache")

wapperdude

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4449
  • Ideas Visio-lized into solutions
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #21 on: March 23, 2022, 04:22:06 PM »
Very cool!   Hopefully that is the solution!!! 😀😀😀
Visio 2019 Pro

Surrogate

  • Hero Member
  • *****
  • Posts: 1630
    • ShapeSheet™ Knowledge Base
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #22 on: March 28, 2022, 01:19:31 PM »
Today my colleague encountered such a problem!
Lenovo laptop, the document contains Cisco stencils etc.

vojo

  • Hero Member
  • *****
  • Posts: 1675
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #23 on: March 28, 2022, 01:56:12 PM »
my fix still works

control panel ==> system & maintenance ==>system ==>advanced system settings ==> performance options ==>advanced settings ==>Virtual memory ==> custom cache size.



Surrogate

  • Hero Member
  • *****
  • Posts: 1630
    • ShapeSheet™ Knowledge Base
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #24 on: March 28, 2022, 04:03:25 PM »
Symptoms at my side
Today I also encountered this situation: when trying to open one of the documents, Visio closed at some point during the opening of the file.
Attempting to open any other file also causes the application to close. This is because the previous session of the Visio application was not closed correctly.
Visio tries to open the last file opened, after which the application closes again abnormally. And everything goes in a circle :wall:
How to break this vicious circle ?
Make the problem file inaccessible:
  • Delete or rename the problem file (if locally hosted);
  • disable wired/wireless connection of the computer (when hosted on a network share).
Opening regular documents
I was lucky after I made the problem file inaccessible other documents started to open :mrgreen:
But my colleague was not so lucky, on forums there is an advice - to disable optimization of extended metafile.
File -> Options -> Advanced -> Display -> Disable advanced metafile optimization.
Putting a checkmark in this item did not help. We did the same thing by adding a parameter in the Windows registry.
\HKEY_CURRENT_USER/SOFTWARE\Microsoft\Office\16.0\Visio\Application\
Key Name : DisableEMFOptimizations
Value : 1
How to fix problem file
The mentioning of EMF optimization gave me an idea how to fix the problem file:
Opened the problem vsdx file with the IZArc archiver
Opened the subfolder "media" and there was an emf-file about 20MB !

After deleting it, vsdx document became possible to open!

vojo

  • Hero Member
  • *****
  • Posts: 1675
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #25 on: March 28, 2022, 06:09:24 PM »
FWIW, I have a media directory as well...about 17MB...I can still open 8MB visio drawings with the cache fix
Not saying your fix is wrong...more saying I dont think my problem is same as yours.

Surrogate

  • Hero Member
  • *****
  • Posts: 1630
    • ShapeSheet™ Knowledge Base
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #26 on: March 30, 2022, 06:10:33 AM »
control panel ==> system & maintenance ==>system ==>advanced system settings ==> performance options ==>advanced settings ==>Virtual memory ==> custom cache size.
Today i get new file from my boss.
I set Maximum paging file size to 8000 and reload notebook. After these actions, the file still would not open
I open it in IZArc application.

Еhis time the problem was with two Visio files in the folder embeddings. After deleting them the document started to open !
« Last Edit: March 30, 2022, 09:38:50 AM by Surrogate »

vojo

  • Hero Member
  • *****
  • Posts: 1675
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #27 on: March 30, 2022, 09:31:22 AM »
my drawing in question was 8 MB in size.   What is yours?
My page cache settings was min=4000 (4GB)  Max = 8000 (8GB).....max is roughly half the DRAM I have in the system.
all I can say is you may want to try to up the max number to say 12000 and see.

Since MS community has, as usual, no clue, I wouldnt expect a solution from MS any time soon
(definitely, one group of programmers who deserve a refund from their respective alma maters   >:(  )


Surrogate

  • Hero Member
  • *****
  • Posts: 1630
    • ShapeSheet™ Knowledge Base
Re: Visio no longer opens drawings ==>crashes with no msgs
« Reply #28 on: March 30, 2022, 09:41:03 AM »
I set Maximum paging file size to 8000 and reload notebook. After these actions, the file still would not open
I overlooked in the option Disable advanced metafile optimization is not checked again.
My DRAM is 8Gb…
« Last Edit: March 30, 2022, 09:43:39 AM by Surrogate »