Author Topic: Colors being WEIRD!  (Read 738 times)

0 Members and 1 Guest are viewing this topic.

kevinleesmith

  • Newbie
  • *
  • Posts: 6
Colors being WEIRD!
« on: September 11, 2020, 07:48:44 AM »
I have a larger file with many boxes with many colour and a macro that puts the RGB and HSL values into the shapes for easy reference.
Then I noticed some boxes were not relfecting the RGB and HSL values I had set in them and thought it was somethign wrong with my code.

After invetigating I have norrowed it down to totally exclude my code.

If I open the test file, change the colout using hte colout picker, it changes to cour in the picker and then the shape when i press OK.

HOWEVER, if I go back into the colout picker again, the color picker now shows a totally different color than the colour showing in the shape!!!!

If you look at the shapesheet, the shapesheet and the shape color match, but neither of those match the colour displayed in the shape picker!!!

I have tried copying the shapes etc to a new file, just incase the file is somewhoe corrupted in a strange way, but while this seems to temporarily fix the problem, as I add more shapes and more colours, the problem happens again.....

This is the vsd
https://www.dropbox.com/s/a8qn69rl0mgydcj/TESTING1.vsd?dl=0

Heres a video of the weirdness happening..
https://www.dropbox.com/s/1e1q1yg57swnia4/2020-09-11%2013-41-01.mp4?dl=0


Surrogate

  • Hero Member
  • *****
  • Posts: 1052
    • ShapeSheet™ Knowledge Base
Re: Colors being WEIRD!
« Reply #1 on: September 11, 2020, 08:26:12 AM »
Hi, Kevin !

But if you use Format Shape pane, there you can see correct RGB components ?
« Last Edit: September 11, 2020, 10:31:59 AM by Surrogate »

kevinleesmith

  • Newbie
  • *
  • Posts: 6
Re: Colors being WEIRD!
« Reply #2 on: September 12, 2020, 08:31:09 AM »
I am using visio 2010...

wapperdude

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3835
  • Ideas Visio-lized into solutions
Re: Colors being WEIRD!
« Reply #3 on: September 12, 2020, 09:29:38 PM »
I was able to confirm the problem with V2019.  I copied the problem shape to a new drawing.  The problem disappears.  Haven't progressed any further, but would seem to be issue with your file.

Just copied all contents of your demo page, and placed in new file.  Still no problem.

Based upon minimal testing, it looks like if you change your color.  Then save the file.  The expected behavior returns to normal.

The overall behavior still seems weird... I wouldn't be so quick to exonerate your code.  It does seem like the GUI interface has been whacked.
« Last Edit: September 12, 2020, 10:11:10 PM by wapperdude »
Visio 2019 Pro

kevinleesmith

  • Newbie
  • *
  • Posts: 6
Re: Colors being WEIRD!
« Reply #4 on: September 13, 2020, 12:44:21 PM »
As I said...


I have tried copying the shapes etc to a new file, just incase the file is somewhoe corrupted in a strange way, but while this seems to temporarily fix the problem, as I add more shapes and more colours, the problem happens again.....

wapperdude

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3835
  • Ideas Visio-lized into solutions
Re: Colors being WEIRD!
« Reply #5 on: September 13, 2020, 01:08:06 PM »
Just to clarify, when you copy to new file, you mean a. Correct? file that does not have any of your code? 

Assuming no code, with just a few shapes, all works fine?  At some point, adding a bunch of shapes causes problems.  Can you add same bunch to a different, new file?  Just this bunch only.  Does the file remain OK, or does it now have problem?  Looking to see if there's a corrupt shape.

Visio 2019 Pro

kevinleesmith

  • Newbie
  • *
  • Posts: 6
Re: Colors being WEIRD!
« Reply #6 on: September 14, 2020, 10:20:34 AM »
Can we all agree that when the colour dialog is not showing you the same RGB valus as the shapesheets says, there is a bug in visio?

wapperdude

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3835
  • Ideas Visio-lized into solutions
Re: Colors being WEIRD!
« Reply #7 on: September 14, 2020, 12:24:17 PM »
Nope.  Not yet.  Still need more info from you...
1) Confirm that new file has none of your coding.
2) You've eliminated possibility that a corrupt shape is contributing to the issue.  If nothing else, copy she a pre over in different order...to see if error appears sooner or later or if it's always at same shape count.

Declaring a Visio bug has no benefit.  This is not a MS/Visio sponsored site.  It merely closes this topic and doesn't resolve anything.  Up to you. 
Visio 2019 Pro

Surrogate

  • Hero Member
  • *****
  • Posts: 1052
    • ShapeSheet™ Knowledge Base
Re: Colors being WEIRD!
« Reply #8 on: September 14, 2020, 03:57:47 PM »
Declaring a Visio bug has no benefit.  This is not a MS/Visio sponsored site.  It merely closes this topic and doesn't resolve anything.  Up to you.
Visio suggestion box is there, but i am not sure that M$FT will fix bugs from very old version (2010)....
« Last Edit: September 14, 2020, 04:01:06 PM by Surrogate »