News:

BB code in posts seems to be working again!
I haven't turned on every single tag, so please let me know if there are any that are used/needed but not activated.

Main Menu

All attachments in forum are php

Started by vojo, December 01, 2011, 09:07:30 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

vojo

For the last few weeks....all the attachments posted in the forum show up only as php files (ie cant open or download them)
I am using firefox.

I dont think I made any browser changes....any advice?

Paul Herber

All fine here, I downloaded a zip fle just today.
An example, from the laboratory stencils thread, the attachment address shows up as
http://visguy.com/vgforum/index.php?action=dlattach;topic=770.0;attach=438
HTH
Electronic and Electrical engineering, business and software stencils for Visio -

https://www.paulherber.co.uk/

Stefan

I agree with vojo, using Firefox all the downloads are in php format and I am unable to open them.
Stefan

Stefan

Checked using Explorer and they open as rar files as expected hence must be a firefox related problem, have not yet checked using Chrome
Stefan

wapperdude

Using IE, and no issues.  All files come up in native format as posted, e.g., vsd, png, etc.
Visio 2019 Pro

vojo

problem is with browsers.....apparently, up until recently, some browsers like firefox us wild cards in some file name lookup.   Unfortunately, the RFC for this kind of thing
states no wild cards....so results of lookup is nothing found...so just get PHP file

Simple machines has a fix for various browsers....though I have not tried it....."buyer beware"  ;-)

Paul Herber

Vojo, I don't see any problems with any of the installed browsers here. All attachments I've tried seem fine. Do you have a link to SMF for this?
Electronic and Electrical engineering, business and software stencils for Visio -

https://www.paulherber.co.uk/

vojo

its definitely a browser issue....wild card in the file name lookup does not conform to RFCs involved.   Even the engine (simplenegines) for this site has a post / fix on for this.

It appears that most people were pretty lax on adherence to the RFC involved....apparently, something lately has triggered everybody to conform....numerous posts around the internet on this

I started seeing the problem about a month ago. (remember my post from a couple of weeks ago about files showing up s PHP)

Poke around on the web...see for yourself

Paul Herber

I've just updated Firefox on one computer here to the latest version 9.0.1 and all attachments to this forum are fine, vss files are dowloaded as vss files, zip files ditto.
Electronic and Electrical engineering, business and software stencils for Visio -

https://www.paulherber.co.uk/

Browser ID: smf (possibly_robot)
Templates: 4: index (default), Display (default), GenericControls (default), GenericControls (default).
Sub templates: 6: init, html_above, body_above, main, body_below, html_below.
Language files: 4: index+Modifications.english (default), Post.english (default), Editor.english (default), Drafts.english (default).
Style sheets: 4: index.css, attachments.css, jquery.sceditor.css, responsive.css.
Hooks called: 285 (show)
Files included: 34 - 1306KB. (show)
Memory used: 1145KB.
Tokens: post-login.
Cache hits: 13: 0.00147s for 26,767 bytes (show)
Cache misses: 2: (show)
Queries used: 17.

[Show Queries]