BB code in posts seems to be working again!
I haven't turned on every single tag, so please let me know if there are any that are used/needed but not activated.

Main Menu

Getting used to 2016 from 2010 - Embedded Excel worksheet question

Started by dsmall, July 17, 2019, 02:29:33 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi all, we have recently transitioned from 2010 to 2016 and still getting used to some of the differences, looking for feedback about embedding Excel worksheet in Visio.

Previously in 2010 I could highlight a group of cells and "Paste Special" into Visio.  Double clicking the Excel shape would open it up externally in Excel for editing.  Now in 2016 I do the same process but double clicking opens up an internal worksheet editor instead of Excel.  For a few reasons this is more limited and frustrating then editing externally.  Is there a way to force the worksheet to open in Excel?

Previously I had Office 2010/Visio 2010 but now have Visio 2016/Office 2016.



Searching the internet, this appears to be an Office 2016 installation problem, not a Visio 2016 issue.  To verify, try putting your Excel selection into Word or PP.  Then, double click.  Should see the same issue.   

See this:
Visio 2019 Pro


Thanks for the feedback!  Using the suggestion in the link I repaired my Office installation but the behaviour is the same.  I tried doing the same thing in Word and PP but both of those programs deal with Excel objects differently and was not able to replicate the issue.


I'm running V2019 Pro plus Office 10.  Copying a section of an Excel file, doing a paste special into V2019 or Word, closing the open Excel file, then dbl clicking the worksheet object in either Visio or Word opens the Excel app and the contents for editing.  This makes me believe that either Office16 behavior has been changed, or there's a bug, or there's perhaps a setting somewhere in the Office apps, e.g., Excel, that hasn't been set properly.

Pretty sure this isn't a Visio issue...don't recall it coming up on the forum before.
Visio 2019 Pro


After a bit more tinkering, I think I found the cause but still not a happy resolution.  If I right-click on the worksheet, navigate to "Worksheet Object", and choose "Open" it will open in Excel, success!  If I choose "Edit" it opens in Visio's worksheet editor, so double-clicking the worksheet must equal "Edit".  It would be great to change that to "Open" but if that's not possible at least I know a workaround now!

Browser ID: smf (possibly_robot)
Templates: 4: index (default), Display (default), GenericControls (default), GenericControls (default).
Sub templates: 6: init, html_above, body_above, main, body_below, html_below.
Language files: 4: index+Modifications.english (default), Post.english (default), Editor.english (default), Drafts.english (default).
Style sheets: 4: index.css, attachments.css, jquery.sceditor.css, responsive.css.
Hooks called: 206 (show)
Files included: 32 - 1207KB. (show)
Memory used: 1042KB.
Tokens: post-login.
Cache hits: 13: 0.00131s for 26,764 bytes (show)
Cache misses: 2: (show)
Queries used: 16.

[Show Queries]