News:

BB code in posts seems to be working again!
I haven't turned on every single tag, so please let me know if there are any that are used/needed but not activated.

Main Menu

Visio 2013 and stencils on a network share issue

Started by Nikolay, April 09, 2015, 12:33:27 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Nikolay

Hi guys,

Facing the following issue for several users..

Suppose you have Visio 2013, and save your (custom) stencils on a network share.
(1) User opens some drawing with a (custom) stencil, then right-clicks to open stencil for editing, edits it, then saves and closes it.
(2) Another user tries to do the same thing from a different computer now (open stencil for editing).
At this point, you occasionally get a message that "file is opened in another instance of Visio", although it's actually not.
The issue appears to be that a hidden temporary "lock" file created at step (1) is not deleted sometimes by the "first" Visio.
If you manually delete that hidden file next to the stencil file, everything is back to normal.

This happens only in Visio 2013, and only if the stencils are stored on a network share (seems to never happen locally and never with previous releases of Visio)
It is not important, which stencil it is, the only important thing is that it's opened from a network share.

Has anyone observed this behavior? Is it a known issue? What can be done about it?

wapperdude

This is just a guess at a possible work around as I don't have V2013 nor involved with your configuration.  You might try closing the Visio file before exiting Visio.  Perhaps the extra step might help.  Just a guess.

Wapperdude
Visio 2019 Pro

Nikolay

Thanks! The thing is it's a bit hard to reproduce this - it just happens occasionally.. But often enough to become annoying.
Will try the suggestion!

HFD_Pete

I am running into this exact issue. It's frustrating because we have 43 work sites using the network shared stencils and once this happens, all other users are affected. When they open a document that uses these stencils, they get an error message and the stencil will not open. That even happens to user who are not trying to "edit" the stencil, just use it and drag symbols from it to place on their document.

I tried making windows display hidden files in the network folder where I store the shared stencils, but I don't see any hidden files that can be deleted to fix the issue. I've tried duplicating the stencil and deleting the locked one, but even that only works if I give the duplicated stencil a new name. I can't be doing that every time this happens.

Has anyone else solved this issue?

HFD_Pete

Follow up to my last post.

Thanks Nikolai for your deleting file fix. In addition to making hidden files visible, I had to uncheck Hide protected system operating files. Then the "lock" temp files became visible and after deleting, the stencils were usable.

I am still looking for a better solution because I can't keep checking this several times a day. In the meantime I'm going to place my stencils in a read only directory and limit the users who can edit the stencil to hopefully reduce the occurrences. Most users should just be using the stencils as is.

Mahalo,
Pete

AnotherNoone

I expierienced the same problem using visio 2010 and 2016 (while other users also used 2013).
We solved the problem by taking away write-permissions on the stencil folder for everyone except for one user, who gets all change-requests etc.

Browser ID: smf (possibly_robot)
Templates: 4: index (default), Display (default), GenericControls (default), GenericControls (default).
Sub templates: 6: init, html_above, body_above, main, body_below, html_below.
Language files: 4: index+Modifications.english (default), Post.english (default), Editor.english (default), Drafts.english (default).
Style sheets: 4: index.css, attachments.css, jquery.sceditor.css, responsive.css.
Hooks called: 239 (show)
Files included: 34 - 1306KB. (show)
Memory used: 1128KB.
Tokens: post-login.
Cache hits: 14: 0.00168s for 26,764 bytes (show)
Cache misses: 3: (show)
Queries used: 17.

[Show Queries]