News:

BB code in posts seems to be working again!
I haven't turned on every single tag, so please let me know if there are any that are used/needed but not activated.

Main Menu

Error HRESULT E_FAIL has been returned from a call to a COM component.

Started by SuyogK, January 21, 2009, 06:55:39 AM

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.

SuyogK

Hi,

Following is the line of code which i am using to call toolbar functionality from office toolbar.

public void ShowCommandBars(int pId)
{
int index;
index = pId;

Microsoft.Office.Core.CommandBars theCommandBars;
ViosCmd.Application theApplication = axDrawingControl.Window.Application;
theCommandBars = (Microsoft.Office.Core.CommandBars)
theApplication.CommandBars;

theCommandBars[pId].Position = Microsoft.Office.Core.MsoBarPosition.msoBarFloating;
theCommandBars[pId].Visible = true;
}

while executing last line (i.e theCommandBars[pId].Visible = true;)
It give me :- Error HRESULT E_FAIL has been returned from a call to a COM component.
Please give me asolution to solve the same.

thanks,
Suyog

Browser ID: smf (possibly_robot)
Templates: 4: index (default), Display (default), GenericControls (default), GenericControls (default).
Sub templates: 6: init, html_above, body_above, main, body_below, html_below.
Language files: 4: index+Modifications.english (default), Post.english (default), Editor.english (default), Drafts.english (default).
Style sheets: 4: index.css, attachments.css, jquery.sceditor.css, responsive.css.
Hooks called: 130 (show)
Files included: 34 - 1306KB. (show)
Memory used: 1045KB.
Tokens: post-login.
Cache hits: 13: 0.00157s for 26,766 bytes (show)
Cache misses: 2: (show)
Queries used: 15.

[Show Queries]