News:

BB code in posts seems to be working again!
I haven't turned on every single tag, so please let me know if there are any that are used/needed but not activated.

Main Menu

Setting zoom mode in Visio 2013 via the registry

Started by stygge, June 26, 2013, 03:35:36 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

stygge

I have an exe-file that sets ZoomMode and ZoomOnRoll to 1 in the registry. It works fine but when I start Visio 2013 they are set back to 0. The same thing happens if I change the values in the registry manually. I don't have this problem in Visio 2010. A bug?

/Staffan Söderholm

Paul Herber

In Visio 2013 check Options -> Advanced -> General
and see if "Put all settings in Windows Registry" is checked.
If not then Visio 2013 is using its own options settings and ignoring the registry settings.
Electronic and Electrical engineering, business and software stencils for Visio -

https://www.paulherber.co.uk/

stygge

Thanks Paul, but it didn't help. I have some other registry keys changed without any problem like TemplatePath, StencilPath and SizePosDisplay. It's only ZoomOnRoll and ZoomMode that Visio changes back to it's original value when started. Also, in Visio 2010 I didn't have this problem.

Browser ID: smf (possibly_robot)
Templates: 4: index (default), Display (default), GenericControls (default), GenericControls (default).
Sub templates: 6: init, html_above, body_above, main, body_below, html_below.
Language files: 4: index+Modifications.english (default), Post.english (default), Editor.english (default), Drafts.english (default).
Style sheets: 4: index.css, attachments.css, jquery.sceditor.css, responsive.css.
Hooks called: 172 (show)
Files included: 34 - 1306KB. (show)
Memory used: 1051KB.
Tokens: post-login.
Cache hits: 13: 0.00143s for 26,766 bytes (show)
Cache misses: 2: (show)
Queries used: 15.

[Show Queries]