News:

BB code in posts seems to be working again!
I haven't turned on every single tag, so please let me know if there are any that are used/needed but not activated.

Main Menu

Visio report not counting shapes inside a group

Started by abssorb, February 15, 2012, 04:06:48 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

abssorb

Hi, this is an odd one.  In Visio 2003 I'm running a report to get data from shapes.  Each shape which is in scope for the report has user.report=1 in its shapesheet.

The report look for all shapes with user.report=1, and then extracts the status of another field: user.shapestatus.

It works well, except there are some anomalies in the figures compared with counting a total on a printout.  After some investigation is comes down to one group which has three shapes inside it, for some reason the report ignores these shapes.  If I ungroup, all is well and the totals match.  There are other groups too, and their shapes are counted without a problem.

Any suggestions welcome.

Browser ID: smf (possibly_robot)
Templates: 4: index (default), Display (default), GenericControls (default), GenericControls (default).
Sub templates: 6: init, html_above, body_above, main, body_below, html_below.
Language files: 4: index+Modifications.english (default), Post.english (default), Editor.english (default), Drafts.english (default).
Style sheets: 4: index.css, attachments.css, jquery.sceditor.css, responsive.css.
Hooks called: 136 (show)
Files included: 34 - 1306KB. (show)
Memory used: 1047KB.
Tokens: post-login.
Cache hits: 13: 0.00139s for 26,767 bytes (show)
Cache misses: 2: (show)
Queries used: 15.

[Show Queries]