News:

BB code in posts seems to be working again!
I haven't turned on every single tag, so please let me know if there are any that are used/needed but not activated.

Main Menu

How to avoid connection points gluing to line segments in a shape

Started by hhals, April 28, 2011, 12:08:32 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

hhals

Hi
I am trying to draw up control loop diagrams in Visio and have made some master shapes for this.
The idea was to utilize connections points in these master shapes for attaching connectors.
My problem lies in that the connecting points in these shapes will glue to line segments in other shapes (indicated by red squares when near) and then when moving one of the shapes, one of the shapes will become distorted.
What I have done is making the graphics for the shapes, added connection points and grouped the lot. In the Snap & Glue panel I have turned off all but "Snap to Grid" and "Glue to connection points". Under the Advanced tab all "Shape extension options" are all deselected and only "Snap strength" for Grid is set to Strong (30) all other is set to Weak (1).
I know that combining the graphic elements will prevent my problem but then I don't seem to be able to combine different line types in the graphics.
I also use shape data to change the number of connection points visualized in the shapes but the invisible connection points also try to connect ever though I have disabled snap (IsSnapTarget) in the Shape sheet.

How can I avoid that the connecting points glues to shape graphic elements as for other to use this tool I need to make it more robust.
Thanks

Jumpy

Do I understand you right:

You glue lines, that a part of a grouped shape
to connection points on shapes, that are part of another grouped shape?

hhals

Hi
My intention is to connect the shapes using connectors and that works ok, all connection points is of the "Inward" type so two shapes should not connect each other.
My problem is that, if I move a shape so that its connection points overlaps endpoints of line segments in another shape (group of graphic and connection points), the connection point's glues to these line endpoints.
It also happens if I draw a line segment and move a shape so its connection points meet the end points of the line segment.
Is there a way to prevent this?

Thanks

Jumpy

Hello hhals,

what you describe is the normal (and often desired (but not from you)) behaviour.

It doesn't matter if you move a line end to a connection point, or a connection point to the line end: Glueing will happen.



How to prevent that? Sorry, don't know. Maybe one of the others here has an idea.

Wasn't there an option in the ShapeSheet for a line (1d shape) to disable glueing completly for that line-shape?

Jumpy

Quote from: hhals on April 28, 2011, 12:08:32 PM
I know that combining the graphic elements will prevent my problem but then I don’t seem to be able to combine different line types in the graphics. I also use shape data to change the number of connection points visualized in the shapes but the invisible connection points also try to connect ever though I have disabled snap (IsSnapTarget) in the Shape sheet.

Again for understanding. You used "internal" connection points to create/build a (grouped) shape from different shapes / different lines. Those "internal" Connection points are than not necessary anymore and are now causing the trouble?
In that case: Can't you delete them and hold the shape together with guarded shapesheet formulas?

hhals

Hi Jumpy
I'm not sure what you mean by "internal" connection points, I only use Connection points where I want connectors to attach the shape. Can you please tell some more about guarded shapesheet formulares.

Thanks

Visio Guy

It sounds like you have Glue to Vertices and Glue to Geometry activated...

Also, there is a check box under Format > Behavior (Developer > Shape Design > Behavior) that says "Snap to member shapes". Use this to turn off snapping (and gluing?) to sub-shapes inside of a group.
For articles, tips and free content, see the Visio Guy Website at http://www.visguy.com
Get my Visio Book! Using Microsoft Visio 2010

hhals

Hi Visio Guy
Both Glue to Vertices and Glue to Geometry is turned off.
I have tried to turn off the "Snap to member shapes" and then I can't attach connectors to my shapes.
Basically the way that I have built my shapes is to
1.   Make up the graphics, including lines symbolizing where to attach connectors
2.   Add connection points to the end of these lines, some of the lines and connection points are grouped to make them invisible through shape data for aromatizing the number of inputs for the shape.
3.   Grouping and shape protection against re-sizing and rotation.
Thanks

Jumpy

Quote from: hhals on May 02, 2011, 07:16:14 AM
Hi Jumpy
I'm not sure what you mean by "internal" connection points, I only use Connection points where I want connectors to attach the shape. Can you please tell some more about guarded shapesheet formulares.

Thanks


Hello,
with internal CPs I meant, what you just explained to Visguy. The Connection Point is not added to the group, but to a shape, that is part of the group. So I won't find that CP in the ShapeSheet of the group but in the ShapeSheet of a shape in the group.

Your problem as I understand it now, is, that the wrong lines (lines that are only part of the "geometry" / the "look" of another shape, lines that are not meant to connect to a CP) now attach themselfs tp the connection points.
To prevent that, you have to guard those lines lineends, which is a piece of work, if you have many lines:
- Select such a line
- Open ShapeSheet
- In for example BeginX change "=3 mm" to =GUARD("3 mm")
- Or if formula change "=Sheet.123!PinX+3 mm" to "=GUARD(Sheet.123!PinX+3 mm)"  //Is only a nonsense formula!
- Do the same for BeginY, EndX, EndY

That is tedious work, so eventually you should use VBA.

johnbtic

I think I know what the problem is and I think I had the same problem.  Go to Tools -> Snap and Glue -> General and uncheck 'Glue'.  This will prevent lines from 'sticking' to other lines, and have lines move that you don't want to move when the line it's glued to is moved.


Paul Herber

Quote from: johnbtic on September 26, 2013, 12:30:44 PM
I think I know what the problem is and I think I had the same problem.  Go to Tools -> Snap and Glue -> General and uncheck 'Glue'.  This will prevent lines from 'sticking' to other lines, and have lines move that you don't want to move when the line it's glued to is moved.

Turning off glue entirely is a bit OTT.
Electronic and Electrical engineering, business and software stencils for Visio -

https://www.paulherber.co.uk/

wapperdude

As previously indicated, this is normal behavior.  As Paul indicates, turning off gluing is OTT.

But there is a solution.  Once you have your grouped shape drawn, select each line segment, right click > behavior > convert to 2-D shape.  The lines will still look like lines, but won't behave as 1-D shapes, and thus, won't glue.

HTH
Wapperdude
Visio 2019 Pro

Browser ID: smf (possibly_robot)
Templates: 4: index (default), Display (default), GenericControls (default), GenericControls (default).
Sub templates: 6: init, html_above, body_above, main, body_below, html_below.
Language files: 4: index+Modifications.english (default), Post.english (default), Editor.english (default), Drafts.english (default).
Style sheets: 4: index.css, attachments.css, jquery.sceditor.css, responsive.css.
Hooks called: 352 (show)
Files included: 34 - 1306KB. (show)
Memory used: 1225KB.
Tokens: post-login.
Cache hits: 13: 0.00249s for 26,767 bytes (show)
Cache misses: 2: (show)
Queries used: 15.

[Show Queries]