News:

BB code in posts seems to be working again!
I haven't turned on every single tag, so please let me know if there are any that are used/needed but not activated.

Main Menu

Colors not Changing

Started by JimR, August 08, 2008, 05:49:35 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

JimR

Hi,

Hope this isn't too basic a question. I have a Visio drawing that someone else did and I need to edit. (I'm still using Visio 2002). I'm trying to change the color of the line or fill or text and it won't take. When I select the shape, and do FORMAT -> FILL, (or Line or Text), it says the the shape has that color, but it's not displaying. It's probably a simple change but I've looked all over and can't seem to find it.

Any info will be very helpful. Thanks in advance!

JIM

Paul Herber

Check whether the shape is a group. The fill may be being supplied by one of the grouped shape's subshapes.

menu View -> Document Explorer Window
explore the appropriate page and then find the shape. A grouped shape will have a set of subshapes. Select that subshape in the explorer window and then apply the colour fill.



Electronic and Electrical engineering, business and software stencils for Visio -

https://www.paulherber.co.uk/

JimR

Hi Paul,

Thanks for the suggestion. I tried it and unfortunately, it didn't work. I think there's a switch or preference that has to be changed somewhere, but I'm not sure where. When I create new shapes from scratch (like a simple circle or square), they seem to be carrying the same characteristics as the shapes that are already on the drawing. But still the color won't changed. Not sure where to go from here.

JIM

Paul Herber

Post an example drawing and we can take a look.
Electronic and Electrical engineering, business and software stencils for Visio -

https://www.paulherber.co.uk/

Visio Guy

Is your shape non-filled? Ie: it has no color and no fill - you can see shapes and the grid behind your shape?
For articles, tips and free content, see the Visio Guy Website at http://www.visguy.com
Get my Visio Book! Using Microsoft Visio 2010

JimR

Visio Guy,

I have it both ways. With and without a visible fill.

Paul,

I tried attaching a simple drawing. It's called Color_Fill.vsd

JIM

Visio Guy

Jim,

I have NO idea why your shape won't fill. But I do know how to fix it: if you Fragment it, Visio creates a new shape that is identical, but will now take a fill color.

1. Select the Shape
2. Choose: Shape > Operations > Fragment
3. Your shape will now behave

Usually, you fragment two or more shapes to "slice and dice" the overlapping bits. In this case, you are cutting one shape with itself, which theoretically does nothing, but it does create a new shape.

No idea what was wrong with your shape.
For articles, tips and free content, see the Visio Guy Website at http://www.visguy.com
Get my Visio Book! Using Microsoft Visio 2010

wapperdude

The reason why the shape won't take a line color or fill color is because it consists of a huge amount of disconnected line segments.  Identify the entire shape, then go to shape operations and use join.  At least that works on the left pattern.
Visio 2019 Pro

Paul Herber

#8
Shape 1: the 2 geometry sections are both set to NOFILL
Shapes 1 and 2 are both members of a layer which has a colour property set. This layer colour overrides the individual shape colours.
Shape 3: the fill colour is a guarded formula that is set to the line colour. Just replace the shapesheet formula with the required colour value.


Electronic and Electrical engineering, business and software stencils for Visio -

https://www.paulherber.co.uk/

vojo

make sure the fillforegnd does not have a guard(  ) function.

I typically do the following:
    - let user set color at the group level even though nothing shows
    - calculate color offsets (for example for shading or light source reasons)
    - store results in a user cells at group level
    - in a given subshape, the fillforegnd = guard(<group id>!user.color<face of interest>)

This allows the shape to intrepret the correct color to apply.

The creator of your shape may have a variant of this for some reason
Also...check that protection==>format is not checked.
   

JimR

Hi All,

Thanks so much for all the solutions. I need to go through and try them individually and perhaps in combination to see what will work. I'll let you know!

JIM

JimR

Hi all,

The solutions did work!  :D Mostly, the NOFILL options did it. But I did have a problem viewing them in the original sheet they were in. Once I copied the whole drawing to a new sheet, the fill colors came out. I also turned all the guards off, just to be on the safe side.

Thanks again!

JIM

chriswolf

I am using Visio-2010 and when this issue happened to me, I needed to select the shape, right-click, "Format" then uncheck "Allow Themes".

Browser ID: smf (possibly_robot)
Templates: 4: index (default), Display (default), GenericControls (default), GenericControls (default).
Sub templates: 6: init, html_above, body_above, main, body_below, html_below.
Language files: 4: index+Modifications.english (default), Post.english (default), Editor.english (default), Drafts.english (default).
Style sheets: 4: index.css, attachments.css, jquery.sceditor.css, responsive.css.
Hooks called: 375 (show)
Files included: 34 - 1306KB. (show)
Memory used: 1241KB.
Tokens: post-login.
Cache hits: 13: 0.00182s for 26,766 bytes (show)
Cache misses: 2: (show)
Queries used: 15.

[Show Queries]