News:

BB code in posts seems to be working again!
I haven't turned on every single tag, so please let me know if there are any that are used/needed but not activated.

Main Menu

Visio Lines are Connected but Cannot be Filled

Started by VG-James, February 09, 2010, 05:25:12 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

VG-James

Ok, I did a freeform line.



Seemed straight forward however, I cannot for the life of me "Fill" this shape.  I've grouped it, gone over every inch of the line to make sure there were no open spots, etc.

Visio Pro 2003 is my current version.

Any suggestions?

Thanks,

James

wapperdude

#1
Grouping will not make it fill-able.  You need to go to Shapes > Operations > Join.  Then it should fill.  If not, open the shapesheet, scroll to the Geometry section and make sure the entry Geometry1.NoFill is set to false.

Wapperdude
Visio 2019 Pro

VG-James

#2
Ok, did the first part (did not do anything different), but not the second.  I'm not sure I understand what you mean by "Open the Shape Sheet, etc".

The other thing of note on this (which may be affecting the first issue) is that this was a building plan, and all the walls, which originally started out as 4" thick, all turned to lines at some point (no thinckness) over the last week while working with this file.

Thanks for your assistance.

James

wapperdude

#3
Hi James --

Sorry, should have explained it better..

Let me re-cap:  
1.  I would ungroup the shape.
2.  Verify that the end points overlay each other, exactly.
3.  Identify both shapes, and then do the Shape > Operations > Join.
4.  Then apply the fill.  If that doesn't work, then,
5.  With the shape selected, go to Window > Show Shapesheet.
6.  Scroll down to the Geometry section if it's not already visible.  There should only be Geometry1.
7.  Upper left corner has the entry:  Geometry1.NoFill.  In the box (cell), to the right make sure it says "False".  If it says "True", just type in a "0", no quotes.  Visio will convert it to false.

Now your shape should take on the fill color/pattern.

HTH
Wapperdude
Visio 2019 Pro

Visio Guy

#4
Another member had a similar problem, check out: Fill problem with custom created shape.
For articles, tips and free content, see the Visio Guy Website at http://www.visguy.com
Get my Visio Book! Using Microsoft Visio 2010

VG-James

Ok, we are close(r).  :-\ Changing NoFill to False gave me this:



I removed the fill and re-added the fill, but same results as you can see above.


Thanks for all your help so far :)

James

wapperdude

#6
When you opened the shapesheet, was there more than 1 Geometry section?  Perhaps 2 or more.  This looks like the end points were not aligned before joining.

My hunch is that you have 2 geometry sections.  The quick fix would be to set the Geometry2 NoFill to false.  The better fix would be to align the end points before joining.  Since the shapes are close -- make sure the Snap setting includes shape vertex.  Then with the pencil tool, select one of the vertical lines, hover the pencil over one end, if you see a "+" sign, click the end to change it to a move symbol, i.e., a "+" with 4 arrow heads.  Now grab the line end and move it away, and then bring it back so it snaps to the vertex of the unmoved shape.  Do this to all four ends.  Now join.  The shapesheet should show JUST one geometry section.   ;)

Could you attach the Visio file?  Here's what I think you have...

Wapperdude
Visio 2019 Pro

VG-James

Thanks WD.  It all worked.  To finalize, had to do the connection point stuff.  Even zoomed in, everything "looked" like it was connected, but in reality I guess it was not.  Snapping to the vertices cleaned it up.  The Geometry1.NoFill had to be changed as well (there was not a Geometry2.NoFill, just as a side note as a possibility of the issues it caused).

And VisioGuy, thanks for the site.  It is quite nice.  ;)

Thanks again,

James

John Distai

This solved the same problem I had.  Thanks!

John Distai

This method works but is really tedious.  Perhaps another way to accomplish the same goal is to draw a large shape, and then draw the appropriate lines and curves intersecting the shape.  The use the Shapes > Operations > Fragment command and delete the un-needed shape.  Its an alternative to trying to match the line ends.

Browser ID: smf (possibly_robot)
Templates: 4: index (default), Display (default), GenericControls (default), GenericControls (default).
Sub templates: 6: init, html_above, body_above, main, body_below, html_below.
Language files: 4: index+Modifications.english (default), Post.english (default), Editor.english (default), Drafts.english (default).
Style sheets: 4: index.css, attachments.css, jquery.sceditor.css, responsive.css.
Hooks called: 325 (show)
Files included: 34 - 1306KB. (show)
Memory used: 1177KB.
Tokens: post-login.
Cache hits: 13: 0.00138s for 26,766 bytes (show)
Cache misses: 2: (show)
Queries used: 16.

[Show Queries]