News:

BB code in posts seems to be working again!
I haven't turned on every single tag, so please let me know if there are any that are used/needed but not activated.

Main Menu

Shape Data adding "Row_99" field following any edit of Shape Data

Started by manifold1978, October 10, 2023, 05:29:03 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

manifold1978

This is driving me nuts!

I have some nicely organised shape data, belonging to a group in a master shape.

I need to make some edits to it, but every time I do, as well as making the change, it adds a "Row_99" (or sometimes another number). The erroneous field only manifests when you drop the shape in from the stencil.
If you go back and define the data from within the master, it all looks fine.

One thing I noticed is that when you drop the shape in from the stencil, it adds a shape data set to the document (not sure if it's meant to do that by default?), and when I go to edit this shape data set, all that's in there is another eroneous "Row_1", nothing else. Another funny thing about this shape data set is that it has a preceeding comma before the first field in the shape data set preview window.

There's 105 fields in total, but I've tried reducing this and I still get the issue.
I've tried starting everything from scracth, both in a new shape and an new document. Same issue.

Everything was fine until today. Now it's started happening and won't stop.

Any ideas?

Surrogate

Quote from: manifold1978 on October 10, 2023, 05:29:03 PM
This is driving me nuts!
You mean something like as Hyperlink.Row_1003?

It is bug, and we cant change it.

wapperdude

Can you explain this
Quotebelonging to a group in a master shape
.  Bit confusing.

Were any PC and/or software updates made before problem started?  What about new apps installed?
Can you try using a different PC?

Do you have a backup?  Does it work OK? 

Can you copy the troublesome Master, close file, start a new file, and paste the Master.  Does problem persist?

Visio 2019 Pro

manifold1978

Thanks for the reply.
What I mean by
Quotebelonging to a group in a master shape
is I have an master shape in my stencil window, inside that shape is a group, and it's the group that has the shape data.
Sorry, my terminooguy is probably not correct!

Anyway, the problem seemed to be an extra entry in the user defined section of the shapesheet (something along the lines of getCPMsetlist, or something?).
Whe I got rid of that, most (but not all) of the shape data went with it, but once I'd reentered without this uder defined row, everything was fine.

None the wiser realy, but at least it works now!

A

Browser ID: smf (possibly_robot)
Templates: 4: index (default), Display (default), GenericControls (default), GenericControls (default).
Sub templates: 6: init, html_above, body_above, main, body_below, html_below.
Language files: 4: index+Modifications.english (default), Post.english (default), Editor.english (default), Drafts.english (default).
Style sheets: 4: index.css, attachments.css, jquery.sceditor.css, responsive.css.
Hooks called: 216 (show)
Files included: 34 - 1306KB. (show)
Memory used: 1065KB.
Tokens: post-login.
Cache hits: 13: 0.00146s for 26,763 bytes (show)
Cache misses: 2: (show)
Queries used: 15.

[Show Queries]