Author Topic: Custom Dynamic Connector (with Labels) -- Behavior issues.  (Read 286 times)

0 Members and 1 Guest are viewing this topic.

Bubba2413

  • Jr. Member
  • **
  • Posts: 12
Custom Dynamic Connector (with Labels) -- Behavior issues.
« on: February 12, 2018, 08:41:54 AM »
ok.. I have two issues with a custom connector shape. 
Background: I've created a connector with 3 labels, tied to data elements. Seems to work ok except:
1.  When connecting to a shape, it only seems to connect at 90 degree points (0/90/180/270) of the shape.  When orbiting a connected shape around the other, the connector "snaps" to the nearest 90degree point on each shape.  A regular dynamic connector does not seem to be constrained to those 90-degree points, but rotates smoothly around the circumference of each connected shape as they orbit around each other.  They do NOT snap at 90deg points on the shapes.  I've compared the shapesheets of both a built-in connector and my 'custom connector', but don't see any differences besides the names.  What am I missing?

2.  shape works fine (except for above).  I can make as many copies as I want, and they all behave the same.  BUT, if I drop it into a stencil, then use the stencil shape, the beginning and end label formulas fail AND formulas in PinX and PinY evaluate to REF#.  If I go to those shapesheet cells and press F2 the formula appears correct.  Make no change, and press enter, and the formula evaluates properly.  Very very strange.


Thoughts on what I'm missing from any of the gurus out there?

« Last Edit: February 12, 2018, 09:06:19 AM by Paul Herber »