Author Topic: Connector angle  (Read 118 times)

0 Members and 1 Guest are viewing this topic.

Gomez

  • Newbie
  • *
  • Posts: 8
Connector angle
« on: November 14, 2017, 04:34:36 AM »
Hello,

I have a little problem with visio 2007.
My connectors act a little bit strangly. A relatively long connector connects to a decision in a 90° angle.
 
This behavior is new to me but I don't think I've changed any options.
I attach two screenshot so you can see what I mean.

The connector should connect like the others in a 180° angle.

I checked the Shapesheet and my snap and glue settings but notice nothing strange.

Yacine

  • Hero Member
  • *****
  • Posts: 2323
Re: Connector angle
« Reply #1 on: November 14, 2017, 03:01:38 PM »
I don't know if snapping and gluing options can cause this behaviour, but you should switch snap and glue to connection point on.
The attached image shows the connection point settings of the standard decision shape. Nothing special to notice.
You can however try to modify them by changing the values of the DirX and DirY columns. The picture shows their influence.
Yacine

wapperdude

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2961
  • Ideas Visio-lized into solutions
Re: Connector angle
« Reply #2 on: November 14, 2017, 06:19:58 PM »
Sometimes, right clicking connector & setting to straight, then a apply the change, then right click again and reset connector helps. 

In addition to Yacine's advice, you can play around with routing styles.

Wapperdude

wapperdude

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2961
  • Ideas Visio-lized into solutions
Re: Connector angle
« Reply #3 on: November 14, 2017, 09:48:34 PM »
I was able to purposefully reproduce this problem.  It has to do with routing style.  Under page properties, or right click the connector and open behavior>routing.  The problem style that I could seletct to get this behavior is "Tree".  The other styles seem to be OK, but I did not check them all.

Wapperdude

Yacine

  • Hero Member
  • *****
  • Posts: 2323
Re: Connector angle
« Reply #4 on: November 15, 2017, 02:40:38 AM »
Interesting indeed.
Yacine

Gomez

  • Newbie
  • *
  • Posts: 8
Re: Connector angle
« Reply #5 on: November 15, 2017, 04:06:36 AM »
Thank you very much :)

@Yacine the shapesheet of my problematic shape also has "no formular" in the DirX and DirY columns.
In my Snap and glue settings "connection point" is already on.

@wapperdude I use the style Waterfall chart like in a other visio file to, where no such errors occure.

I think the problem has nothing to do with the connector cause i use the same connector on a relatively similar shape and there it works perfectly fine.
Perhaps it has something to do with the size of my diagram, perhaps the pathfinding don't work over so much space (My document is 120 cm (~ 50 inches) long, the connector slightly shorter)

On the shapes where this error occurs i can fix the connector manual so it won't bothers me to much.