Weird coloring of shapes

Started by AnotherNoone, August 14, 2017, 12:24:56 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


the shape i posted has the following problem:
when u colorfill it, the small Text field gets filled in a way that makes it stand out.
How can i make it, so that that isnt happening (most importantly WHY is it happening)



Because this shape's text box have white text block background !

Please look this gif-animation :)


Nice GIF, but why the original blind text?

Лорем ипсум долор сит амет, иус не елаборарет перципитур, сит те солум тинцидунт, сед ад омнис персецути. При виси епицуреи принципес но, вим синт дицит патриояуе ан. Пхилосопхиа репрехендунт еи сеа, меи поссе дицтас лаореет ат. Ад иудицо тибияуе елаборарет цум, пхаедрум лобортис репудиандае цу ест. Яуо ад либрис долорум фацилисис, яуандо аццусамус еи про, еи фастидии оффициис еум. Цибо аудире ид дуо. Цум ут губергрен ехпетендис, номинати антиопам ет еос, яуи ан аперири адиписци ехплицари.



That wasn what i meant, the text is supposed to have a white background (you can hide it via right click..)
The problem is, if you select the entire shape and fill it, the entire text field is always standing out (even when the text is currently idden)


There are two "fill" colors that apply to a shape with text.  The obvious fill / fillbackground for normal shape coloring.  Text has an additional coloring, a "highlighting".

From the GUI, you access this via Format > Text > Text Block.
From the shapesheet, just scroll down to the Text Block Format section, then the entry is TextBkgnd. 

If you want these to be the same color, then set the TextBkgnd = FillForegnd.

Visio 2019 Pro


I think, I missexplained my problem. The Text background is supposed to be white, the text field should be filled with the same color like the overall shape, but it doesnt: (pictures are before/after fill)




Please describe how you change color of main shape ?


The "Füllen" button (German for Fill)


1. Select this inner shape

2. Select Fill button and set NoFill option


Is this gonna work, when i refill the entire shape with another color?


1. Look at Developer Tab (Entwicklertools), select Show ShapeSheet ->Shape

2. Delete formulae in highlighted cells

It is reason ot weird :)

After that changes you can make fill of inner shape as you want !


Perfect, thx. Totally missed that.