Author Topic: This morning Visio 2016 IRM activated!  (Read 695 times)

0 Members and 1 Guest are viewing this topic.

JuneTheSecond

  • Hero Member
  • *****
  • Posts: 997
    • Visio Shapes, Stencils and Sample Drawings
This morning Visio 2016 IRM activated!
« on: January 05, 2017, 11:09:10 PM »
I have sent feedback twice or more, complaining that the menu protect diagram does not work at all.
And this morning I found Visio 2016 IRM menu, Files/Information/Protecting Diagram, activated!
Is it an new or a forgotten update?
I had already canceled the subscription of Sharepoint online few days ago,
because in Sharepoint online I failed to set up IRM for sharepoint nor for Visio.
I have only got success in windows RMS by installing free Microsoft Rights Management Services (RMS) for individuals, downloading from the site at https://www.microsoft.com/en-us/cloud-platform/azure-information-protection-pricing. It can protect any files on Windows file explorer.

Now I can execute the 1st example macro in Visio VBA editor to protect Visio file, too at https://msdn.microsoft.com/en-us//library/office/mt210985.aspx.

Code: [Select]
Option Explicit

Sub test()
Dim objPermission As Office.Permission
Dim objUserPerm As Office.UserPermission

Set objPermission = ActiveDocument.Permission

Set objUserPerm = objPermission.Add("Jxxxxd@yxx2.oxxxt.com", msoPermissionView, #12/31/2017#)
MsgBox "Permissions added for " & objUserPerm.UserId, vbInformation = vbOKOnly, "Permissions Added"
Set objUserPerm = Nothing

End Sub



Any way, thank you everybody!

I am sorry attatched pictures have not English text, as my Visio is Jananese version.


« Last Edit: January 06, 2017, 04:27:47 AM by JuneTheSecond »
Best Regards,

Junichi Yoda
http://june.minibird.jp/

Nikolay

  • Hero Member
  • *****
  • Posts: 652
    • UnmanagedVisio
Re: This morning Visio 2016 IRM activated!
« Reply #1 on: January 17, 2017, 04:57:12 AM »
It's really cool that you have managed to make it work!

For me, it worked once, but when I tried to repeat - the menu you show was not there! Damn.
It looks like the feature was designed  to work in corporate environment, it's not that easy to make it work without it..