Author Topic: Snap and Glue "green box" issue  (Read 3603 times)

0 Members and 1 Guest are viewing this topic.

Miki

  • Jr. Member
  • **
  • Posts: 61
Snap and Glue "green box" issue
« on: June 28, 2016, 04:22:41 PM »
Hello,
I have a drawing that has multiple shapes. Some shapes are simple (individual) and some are complex (grouped). I have a master, called "Binder", which is used to connect the shapes on the drawing to a particular shape that is used to identify them using a VBA code. The "Binder" shape is basically a connector with some shape data.
The are 2 issues. First, whenever I try to glue the Binder to the connection point of other shapes, it gives me this green box and then connects the Binder to the center of the shape and not to the connection point.
I solved this issue by setting the "ObjType" in the shapesheet to 4.

The second issue is even after setting the "ObjType" for all the shapes, whenever I drop the Binder on the drawing, this green box appears and the Binder will connect to the center of the shape. How do I get rid of this issue? I cannot turn the snap and glue off because then I won't be able to connect my Binder to the shape's connection point. This only happens when I drag the Binder from the stencil onto the drawing.
I currently drop the shape to an empty area where there are no shapes but this is not a solution.

Does anyone know why this happens and how to solve this?

Here is an image of that green box



- Miki

Miki

  • Jr. Member
  • **
  • Posts: 61
Re: Snap and Glue "green box" issue
« Reply #1 on: June 28, 2016, 04:42:05 PM »
Ah...found it...

Thanks to this post:
http://visguy.com/vgforum/index.php?topic=5066.msg19884#msg19884

One has to set the "GlueType" to "8" for all the shapes to which the Binder will be connected.
This takes away the Dynamic property of the connector, but that was least of my interest.
Hope this helps to someone like me.

- Miki