Author Topic: Help developing a new add-on  (Read 19838 times)

0 Members and 2 Guests are viewing this topic.

Nikolay

  • Hero Member
  • *****
  • Posts: 945
    • UnmanagedVisio
Re: Help developing a new add-on
« Reply #30 on: March 23, 2016, 05:41:47 PM »
That's odd.. can you send the project as zip (the "broken" one, in PM or to my email), so that I can check it / fix the template if needed?
« Last Edit: March 23, 2016, 05:43:53 PM by Nikolay »

perry59

  • Full Member
  • ***
  • Posts: 208
Re: Help developing a new add-on
« Reply #31 on: March 23, 2016, 05:59:14 PM »
That's odd.. can you send the project as zip (the "broken" one, in PM or to my email), so that I can check it / fix the template if needed?
Thanks Nikolay!
I should probably re-install your addon first to see if that changes anything.
I do not see a way to attach a file to a PM and did not see an email address on your profile.

perry59

  • Full Member
  • ***
  • Posts: 208
Re: Help developing a new add-on
« Reply #32 on: March 23, 2016, 06:16:49 PM »
Uninstalling/reinstalling didn't help :o

Nikolay

  • Hero Member
  • *****
  • Posts: 945
    • UnmanagedVisio
Re: Help developing a new add-on
« Reply #33 on: March 23, 2016, 06:48:17 PM »
Ups. Updated the profile (added email)

The wizard only creates the project... After project creation the extension itself not used anymore.
Means, you should be able to open the project even after uninstalling the extension.
« Last Edit: March 23, 2016, 07:05:34 PM by Nikolay »

perry59

  • Full Member
  • ***
  • Posts: 208
Re: Help developing a new add-on
« Reply #34 on: March 24, 2016, 09:58:00 AM »
Ups. Updated the profile (added email)

The wizard only creates the project... After project creation the extension itself not used anymore.
Means, you should be able to open the project even after uninstalling the extension.
I assumed such. But VS is only complaining about my visio projects. I created a couple other projects, windows form, class lib, and it reopened them without complaint. Maybe I should reinstall everything and try again.
BTW, I set up the visio project for 2007, i.e. no ribbon, no 2016 assemblies. Just 2007 toolbars.

perry59

  • Full Member
  • ***
  • Posts: 208
Re: Help developing a new add-on
« Reply #35 on: March 24, 2016, 10:03:13 AM »
Ups. Updated the profile (added email)
Looks like email though this board does not allow attachments either!
I'll attach it here. There's nothing proprietary in there yet.
well, scratch that idea too! the board will not allow anything larger that 500k  >:(
Is it just the .sln file you need to see?

perry59

  • Full Member
  • ***
  • Posts: 208
Re: Help developing a new add-on
« Reply #36 on: March 24, 2016, 10:11:42 AM »
Ok, here's one.
Made a bare bones one, no setup project or panel, this should post.
I still get the "incompatible" error after its created and I try to re-open it.
« Last Edit: March 24, 2016, 10:24:55 AM by perry59 »

perry59

  • Full Member
  • ***
  • Posts: 208
Re: Help developing a new add-on
« Reply #37 on: March 24, 2016, 10:55:17 AM »
Ok, I made a discovery  ;D
I only get an "incompatible" project if I do NOT build the solution before exiting VS.
So, if I make a new project then close it without building, it will not load in VS again.
If I make a new project, then do a build, even though I have not touched the code, then it will open up again in VS just fine.

Nikolay

  • Hero Member
  • *****
  • Posts: 945
    • UnmanagedVisio
Re: Help developing a new add-on
« Reply #38 on: March 24, 2016, 11:37:53 AM »
That's odd. Looks like a bug in generator, most probably has something to do with Visio 2007 and project versions.. Will look at it today.

perry59

  • Full Member
  • ***
  • Posts: 208
Re: Help developing a new add-on
« Reply #39 on: March 24, 2016, 11:44:30 AM »
That's odd. Looks like a bug in generator, most probably has something to do with Visio 2007 and project versions.. Will look at it today.
Thanks Nikolay! glad I could help ???
But at least I know I can use it as long as I do a build before closing VS.

VisioDeveloper

  • Jr. Member
  • **
  • Posts: 24
Re: Help developing a new add-on
« Reply #40 on: April 02, 2016, 01:11:50 PM »
So today i've been having a pretty frustrating experience, and the worst thing is that i'm not even sure where the problem is coming from.

The wix installer creation was working well on the machine i was working on (windows 8.1, VS 2015) but i don't have that machine anymore and i can't rebuild the installer no matter what i do.
Right now i have 2 windows 10 machines with basically everything i had on the other one (VS 2015, latest VSTO, wix 3.11) but i always get the same error when i try to build the setup:

Code
The "ResolveWixReferences" task was not found. Check the following: 
1.) The name of the task in the project file is the same as the name of the task class.
2.) The task class is "public" and implements the Microsoft.Build.Framework.ITask interface.
3.) The task is correctly declared with <UsingTask> in the project file, or in the *.tasks files located in the "C:\Program Files (x86)\MSBuild\14.0\bin" directory.
Setup C:\Program Files (x86)\MSBuild\Microsoft\WiX\v3.x\wix2010.targets Line 772

Tried a fresh install of VS, several wix versions and it doesn't work even with a newly created project. I also found this: https://github.com/wixtoolset/issues/issues/3872 and tried the solution described but no luck. One thing i also noticed is that the WixNetFxExtension and WixUIExtension references do not have a valid path even with a new project.

Right now i'm trying to create a VM to see if it's something to do with windows 10 compatibility.

Edit: Now i'm even more confused, the VM with an identical setup throws the same error. Am i forgetting something or did something break with an update?
« Last Edit: April 02, 2016, 02:48:16 PM by VisioDeveloper »

Nikolay

  • Hero Member
  • *****
  • Posts: 945
    • UnmanagedVisio
Re: Help developing a new add-on
« Reply #41 on: April 02, 2016, 02:47:33 PM »
I would say this is some WIX install problem..

Have you tried uninstalling WIX and then installing it again?
Here is very similar issue reported, it says that after reinstall all is okay:
http://windows-installer-xml-wix-toolset.687559.n2.nabble.com/quot-ResolveWixReferences-quot-task-was-not-found-td5082069.html

I'm running Windows 10, does not seem to experience this issue.

It looks like missing Wix2010 targets.. means that something targets different version of Visual Studio (VS 2010).

VisioDeveloper

  • Jr. Member
  • **
  • Posts: 24
Re: Help developing a new add-on
« Reply #42 on: April 02, 2016, 02:56:53 PM »
I would say this is some WIX install problem..

Have you tried uninstalling WIX and then installing it again?
Here is very similar issue reported, it says that after reinstall all is okay:
http://windows-installer-xml-wix-toolset.687559.n2.nabble.com/quot-ResolveWixReferences-quot-task-was-not-found-td5082069.html

I'm running Windows 10, does not seem to experience this issue.

It looks like missing Wix2010 targets.. means that something targets different version of Visual Studio (VS 2010).

I don't remember which version of wix i had in my original install, which one are you using? Tried v4.0.3922.0 but it doesnt seem to work with the template so i installed v3.11.0.321.

I did this just now:

- fresh install of windows 8.1
- Installed VS Community 2015 Update 2
- Installed wix v3.11.0.321 and VSTO

And when i create a new project from the template i get this:


I've reinstalled wix multiple times on different machines, maybe it's the latest versions?

VisioDeveloper

  • Jr. Member
  • **
  • Posts: 24
Re: Help developing a new add-on
« Reply #43 on: April 02, 2016, 04:17:23 PM »
After hours and hours trying to solve this, turns out the problem is the wix version. 3.10 works but not the newer versions.
Can you confirm if this is related to the template or wix itself?

Nikolay

  • Hero Member
  • *****
  • Posts: 945
    • UnmanagedVisio
Re: Help developing a new add-on
« Reply #44 on: April 02, 2016, 05:08:28 PM »
But the latest released version is 3.10 (3.10.2)? At least I don't see a later one..?
« Last Edit: April 02, 2016, 05:11:22 PM by Nikolay »