Author Topic: Publish fails over bad certificate  (Read 2810 times)

0 Members and 1 Guest are viewing this topic.

nir

  • Newbie
  • *
  • Posts: 9
Publish fails over bad certificate
« on: June 16, 2015, 09:24:59 AM »
Hi all,

We encountered a problem while trying to publish our add-in.
This is the error message:

"Error   8   
An error occurred while signing: Failed to sign bin\Debug\app.publish\\setup.exe. SignTool Error:
No certificates were found that met all the given criteria.   ElectricSchema "

What  should we do ? We've read about pfx files etc. but how can we create them ? do we even need to ?

Thanks.
Nir Putter - software engineer.

Paul Herber

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2829
    • Paul Herber's website
Re: Publish fails over bad certificate
« Reply #1 on: June 16, 2015, 10:09:46 AM »
Do you have a code-signing certificate?
If so then ... you need to get it setup for signing - that's a more complicated story.
If not then either:
1. get a code-signing certificate
2. remove the part of your publishing script that does the code-signing.
Electronic and Electrical engineering, business and software stencils and applications for Visio -

https://www.paulherber.co.uk/

nir

  • Newbie
  • *
  • Posts: 9
Re: Publish fails over bad certificate
« Reply #2 on: June 17, 2015, 07:02:45 AM »
Do you have a code-signing certificate?
If so then ... you need to get it setup for signing - that's a more complicated story.
If not then either:
1. get a code-signing certificate
2. remove the part of your publishing script that does the code-signing.

Hi Paul and thanks for the answer.
We've tried to remove scripting from publish but it keeps re-marking the radio button for certificates.
We're trying now to get a valid certificate file.
Nir Putter - software engineer.