Increasing connector text padding / margin / space

Started by ziipppp, July 11, 2014, 05:16:53 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Sorry, very noob question here - but I'm trying to create a connector line with text on it - without the line practically overrunning the text.
I've hunted this forum and all over, so apparently no one else has this issue?

So take a standard connector.
Click it - hit F2 and type.
Note that the line basically runs right into the text.
You can put a few spaces in front of the text to get the line to back off and give it some breathing room, but spaces behind the text are ignored.
I've gone into the ShapeSheet and mucked about, but nothing I've guess at has moved it.
I went into the Paragraph menu (by clicking the little down arrow in Home/Paragraph) but nothing doing.
Basically I want my line to look like this ‒‒  text  ‒‒  and it looks like this --text-- (looks more cramped in Visio). Thanks again (I'm using Visio 2010 standard)


You can edit the text background property to be white and increase the text margin to wathever value suits you.


Hey thanks Yacine - sadly I'm still not getting it. I know what you mean about the background - but that doesn't seem to fix it.
Let me risk boring the pants off of you, and just going through this step by step.
Draw connector.
Click. And type text.
Select text block tool and select shape ie the 8 little boxes around the text.
Go and select Fill white from the shape ribbon - nothing
Go to Paragraph Tool, select Text Block Tab push up the points on the left and right margin - all that does is push the text back and forth on the line ie its the margin WITHIN the little 8 squared text area - still no padding (yes transparency is set to zero - and just to be sure I made the background a bright color. That shows but the furthest right letter is pushed up against the color.
Aligning left or right or center makes no difference to that padding. Does this make more sense here?
Clearly I'm missing something super dumb - so can you tell me exactly where to click what to do.
In PowerPoint you can manipulate from the Ruler view (and a bunch of other places too) but that doesn't seem to be an option in Visio 2010.

Thanks again for your kindness.


Actually, not super's a feature!  The text for the connector has no, uh, bounding box, so there is no true background, and, no padding. 

Text has two types of background, behind the text (which I suppose is text background), and then background for the text box.  Try experiment, adding text to the page.  Add fill color.  Now, edit the text via format...textblock, and choose a fill color, other than the background color you just added.  Look at the shape, two colors!  The 1st fills the text box, the second just, backlights the text.  Changing the left right margin spacing does change the padding for the textbox fill, but has no impact upon text background.

Basically, what you have is what you get.  You could make a custom connector, add a box for background, but, it's a lot of extra work.

Visio 2019 Pro


@Zip, You are right, I checked again. The text of lines doesn't get the margins of regular texts, despite the options are available.
My suggestion would then be to set up a group in which a text block is included and placed on the foreground.
The text editing option of the group must be disabled in order to edit directly the text subshape, when you press F2.
Width and heigth of the text box are guarded and bound to the minimum of width of the text and the line.
This should roughly meet your needs.


That is very cool and useful, thank you Yacine.
Visio 2003 for production
Visio 2019


Hey thanks WapperDude and Yacine! Glad its not just me :-) Yeah, I was thinking of creating a text box over the line, but then of course it doesn't quite size and bend and flex as the picture flexes. Oh well. Reassured it wasn't something I missed. Thanks again everyone, much appreciated on the detailed response.


Little late to the party but I stumbled upon this thread because this missing "breating space" was bugging me as well.

I found a very simple solution based on ziipppp's trials to add spaces before and behind the text.
Yes, the spaces _behind_ the text seem to get ignored. But not if you use other Unicode whitespaces:
Try copy&pasting some of the whitespaces from this table (column withing ] [) - e.g. EN QUAD en EM QUAD seem to work fine in Visio 2013.