Author Topic: VSL AddIn with MSI Installer does not work with Visio 2013  (Read 5506 times)

0 Members and 1 Guest are viewing this topic.

Sebastian

  • Newbie
  • *
  • Posts: 5
VSL AddIn with MSI Installer does not work with Visio 2013
« on: November 20, 2014, 03:58:41 AM »
Hello Community

Years ago I wrote an AddIn for Visio2003 with some stencils, a template and functions in a vsl file. I used the SDK publish tool to create a proper MSI file.

Right now my customer wants to update to Visio 2013 and I can’t figure out why my installer is not working anymore. Unfortunately I decided (10 years ago) to use Delphi 5 to create the vsl (DLL) file and MakeMSI for the installer. So I am not using much of the Microsoft tool chain.

Now my problem is, that VSL file is not showing up in AddOns after installation. The VSL itself is actually working because when I add the install folder to the ADD-Ons path I see all my functions and they are working.


I checked the PublishedComponent table and played around with LCID, VisioVersion and Edition in the Visio 2013 Solution Publishing Tool – but without success.



Also the Registry entries seem to be all right because the stencils and the template are correctly installed. The SDK VSLs show up in the same registry entry...


The MSI file is not working with Win7 nor with Win8 - I tried it on two computers.

Hope someone can give me a hint what I can try next.

Thank you in advance

Cheers

Sebastian
P.S. I already asked the question on the microsoft community (http://answers.microsoft.com/en-us/office/forum/office_2013_release-visio/vsl-addin-with-msi-installer-does-not-work-with/323a0433-2083-43ca-a35c-a56042807404) without success.

Paul Herber

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2930
    • Paul Herber's website
Re: VSL AddIn with MSI Installer does not work with Visio 2013
« Reply #1 on: November 20, 2014, 06:16:49 AM »
Is the vsl digitally signed, or are Visio's security settings set to allow non-signed addons?
Electronic and Electrical engineering, business and software stencils and applications for Visio -

https://www.paulherber.co.uk/

Nikolay

  • Hero Member
  • *****
  • Posts: 942
    • UnmanagedVisio
Re: VSL AddIn with MSI Installer does not work with Visio 2013
« Reply #2 on: November 20, 2014, 06:41:29 AM »
Could you possibly put your installer (MSI) file here so that we could try it?

I mean, I have messed a while ago with this publishing stuff..
Ended up creating a extension to build MSI from VisualStudio using WiX (does not depend on the publishing tool):
https://visualstudiogallery.msdn.microsoft.com/68d12e2d-eb42-4847-808a-7d80863bb90d
« Last Edit: November 20, 2014, 06:47:01 AM by Nikolay »

Sebastian

  • Newbie
  • *
  • Posts: 5
Re: VSL AddIn with MSI Installer does not work with Visio 2013
« Reply #3 on: November 20, 2014, 04:14:27 PM »
Hello Paul,

The vsl is not signed and all security features in Trust Center\Add-Ins are unchecked. The VSL is running if I add the vsl folder as Add-Ons folder. But the vsl is not running if I use my msi installer...

Cheers
Seb

Nikolay

  • Hero Member
  • *****
  • Posts: 942
    • UnmanagedVisio
Re: VSL AddIn with MSI Installer does not work with Visio 2013
« Reply #4 on: November 20, 2014, 07:11:14 PM »
I've taken a look at the MSI.

1. The main issue seems to be that you don't have VSL as "Key file" for your component.
Just put it as first file in your file list (so that it is "Key file" to the component), and everything should work.
See the screenshot in the attachment (screenshot from ORCA).

2. The Solution publishing tool seems to mess stuff a bit with your setup... 
To allow ALL languages for Visio 2013 (and not only German 1031), you could try setting Language=1
That is, in the MSI in the Qualifer column you should get "1\xx\Rackdesign.vsl".
Note that this does not seem work for all versions (in particular, 2003); only 2007 and above.

3. Come on, move to WiX already :) MAKEMSI sucks :)

Please also mind the PM.

Sebastian

  • Newbie
  • *
  • Posts: 5
Re: VSL AddIn with MSI Installer does not work with Visio 2013
« Reply #5 on: November 23, 2014, 03:44:09 PM »
Hey Nicolay,

Thank you very much – it’s working. Unfortunately I will not change to WiX because of your help  ;).

Thank you very much again!

If you are in Dresden (Germany) for the next time I owe you a beer!

Cheers
Sebastian

Yacine

  • Hero Member
  • *****
  • Posts: 2703
Re: VSL AddIn with MSI Installer does not work with Visio 2013
« Reply #6 on: November 23, 2014, 04:46:42 PM »
Ein lecker Radeberger?
Yacine

Nikolay

  • Hero Member
  • *****
  • Posts: 942
    • UnmanagedVisio
Re: VSL AddIn with MSI Installer does not work with Visio 2013
« Reply #7 on: November 24, 2014, 03:26:06 AM »
Oder zwei