Author Topic: Shape vertices not shown anymore on mouseover  (Read 13367 times)

0 Members and 1 Guest are viewing this topic.

David.P

  • Full Member
  • ***
  • Posts: 172
Shape vertices not shown anymore on mouseover
« on: June 24, 2014, 01:39:41 AM »
Hi forum,

I used to be able to hold the mouse pointer (arrow) over a shape (polyline, rectangle etc.) for like a second, and then the nodes (aka vertices) would appear and become editable with the arrow pointer. This was handy because it was not necessary to change to the pencil tool first.

However, this feature suddenly has disappeared...

Any help on how tho get it back would be appreciated.

Regards David.P
« Last Edit: June 26, 2014, 01:44:30 AM by David.P »
Visio 2003 for production
Visio 2019

David.P

  • Full Member
  • ***
  • Posts: 172
Re: Shape vertices not shown anymore on mouseover
« Reply #1 on: June 26, 2014, 01:49:58 AM »
The behaviour is similar like described here:
http://webpages.dcu.ie/~kennedal/Visio/Visio.htm#_Toc240183734



...with the difference that I didn't even have to use the Line Tool in order to show the vertices (e.g. of a rectangle) on mouseover. I simply had to hold the arrow pointer over the rectangle for a second, and the vertices would appear and be editable. But now no more?

 :-[
Visio 2003 for production
Visio 2019

Surrogate

  • Hero Member
  • *****
  • Posts: 1834
    • ShapeSheet™ Knowledge Base
Re: Shape vertices not shown anymore on mouseover
« Reply #2 on: June 26, 2014, 02:06:48 AM »
David.P,
If you want use pointer for edit vertice like this

you must add control to your shape via ShapeSheet™

David.P

  • Full Member
  • ***
  • Posts: 172
Re: Shape vertices not shown anymore on mouseover
« Reply #3 on: June 26, 2014, 02:13:11 AM »
Thank you Surrogate -- however I used to have this behaviour on all shapes without any changes to the shape sheet.

The behaviour was also somewhat different from your screencast: the vertices would not appear instantly when selecting a shape with the pointer tool, but only after holding mouse still over the shape for about a second.
Visio 2003 for production
Visio 2019

Surrogate

  • Hero Member
  • *****
  • Posts: 1834
    • ShapeSheet™ Knowledge Base
Re: Shape vertices not shown anymore on mouseover
« Reply #4 on: June 26, 2014, 02:28:11 AM »
if you change Behaviors of this shape

you can get

but i don't know how add this behavior to many shapes.
may be write macro

David.P

  • Full Member
  • ***
  • Posts: 172
Re: Shape vertices not shown anymore on mouseover
« Reply #5 on: June 26, 2014, 02:50:05 AM »
This option is active as standard with every shape I create!



Still, the control points (vertices) are not shown when the shape is selected, unfortunately.
Visio 2003 for production
Visio 2019

JohnGoldsmith

  • Sr. Member
  • ****
  • Posts: 358
    • John Goldsmith's visLog
Re: Shape vertices not shown anymore on mouseover
« Reply #6 on: June 26, 2014, 03:25:56 AM »
Hello David,

There's an option on the advanced section - 'Show more shape handles on hover' (see image)

Is that what you're looking for?

Best regards

John
John Goldsmith - Visio MVP
http://visualsignals.typepad.co.uk/

David.P

  • Full Member
  • ***
  • Posts: 172
Re: Shape vertices not shown anymore on mouseover
« Reply #7 on: June 26, 2014, 04:06:14 AM »
Hey John,

that could actually be it! Unfortunately, my 2003 version of Visio doesn't seem to have that option.

I would however suppose that this setting can be found in the registry somewhere... only question is where, or under which Key name?
Visio 2003 for production
Visio 2019

JohnGoldsmith

  • Sr. Member
  • ****
  • Posts: 358
    • John Goldsmith's visLog
Re: Shape vertices not shown anymore on mouseover
« Reply #8 on: June 26, 2014, 06:03:22 AM »
On 2010 the key is at:

HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Visio\Application\HandleBehavior

where 0 = checked and 1 = unchecked (the reverse of what you might expect).

Hope that helps.

Best regards

John
« Last Edit: June 26, 2014, 06:07:28 AM by JohnGoldsmith »
John Goldsmith - Visio MVP
http://visualsignals.typepad.co.uk/

David.P

  • Full Member
  • ***
  • Posts: 172
Re: Shape vertices not shown anymore on mouseover
« Reply #9 on: June 26, 2014, 06:59:55 AM »
Thank you John,

I found the registry key, but it was already set to "0". Setting it to "1" unfortunately did not help.

Any other ideas are also very much appreciated!
Visio 2003 for production
Visio 2019

David.P

  • Full Member
  • ***
  • Posts: 172
Re: Shape vertices not shown anymore on mouseover
« Reply #10 on: June 26, 2014, 08:13:31 AM »
I even have tried and deleted the complete Visio section in the registry, as well as tried some earlier registry backups, but with no avail.

Could anyone of you guys confirm that in your copy of Visio (ideally in v.2003), the described behaviour is present?

Just in case I possibly should be hallucinating.
« Last Edit: June 26, 2014, 11:13:21 AM by David.P »
Visio 2003 for production
Visio 2019

wapperdude

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4878
  • Ideas Visio-lized into solutions
Re: Shape vertices not shown anymore on mouseover
« Reply #11 on: June 26, 2014, 10:38:50 AM »
If V2003 (I've never had that version) is like V2007, then the option that JG is referring to would be under the General tab (menu bar>tools>options>General), not the Advanced tab.  I'm not sure how these options were moved around from version to version.

Anyway, with that option selected, then, select the shape and hover the mouse.  That does produce the behavior you remember.

HTH
Wapperdude
Visio 2019 Pro

David.P

  • Full Member
  • ***
  • Posts: 172
Re: Shape vertices not shown anymore on mouseover
« Reply #12 on: June 26, 2014, 11:11:49 AM »
Thank you Wapper,

in "General", I have only this:



Anyway, changing the setting (that John mentioned) in the registry should have also fixed the problem -- if it would be related to that setting which however it doesn't seem to be.

Therefore, the problem must be related to something else -- only to what?
Visio 2003 for production
Visio 2019

wapperdude

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4878
  • Ideas Visio-lized into solutions
Re: Shape vertices not shown anymore on mouseover
« Reply #13 on: June 26, 2014, 07:31:36 PM »
I can see that V2003 is arranged differently than V2007.  Even though I don't read German, I can tell pretty much which options were showing, and on the General page, there's two more in V2007 than V2003.  Guess, I can't help too much.

That brings us to current check list of possible culprits:
  1.) Is this behavior an issue with only new drawings, or also with old drawings that used to work OK.
  2.) Was software added or updates made at about the time the behavior went away?
        a.)  Could try restoring to an earlier point in time or
        b.)  Try uninstalling offending programs.
        c.)  If new software was installed, was Visio running at the time?  Perhaps something was clobbered.
  3.)  Other than this issue, is Visio working OK?  Did Visio / your computer crash at some point in time?
        a.)  Have you tried to repair Visio?  Don't know if that's a V2003 option.  The installation disk should have this feature.  You might try that.
        b.)  It's possible you may need to do a complete uninstall / reinstall.
 
Wapperdude
Visio 2019 Pro

wapperdude

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4878
  • Ideas Visio-lized into solutions
Re: Shape vertices not shown anymore on mouseover
« Reply #14 on: June 27, 2014, 10:11:33 AM »
Updated observations (and validations):

1.)   From John Goldsmith,
Quote
HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Visio\Application\HandleBehavior

fyi:  Office\14.0\ relates to Office10 release.  For V2007, it would be \12.0\.  Not sure what V2003 is.  It is possible to have Office10 products loaded and an older version of Visio, so, make sure you're correcting the right place.

2.)  Changing the HandleBehavior is the correct key, and, does produce/change the desired behavior.

Presumably, this also functions the same way for V2003.  So, if you did change the correct key, and there is no behavior change, then, I suspect you really do need to repair and/or reinstall Visio.

Wapperdude
Visio 2019 Pro