Author Topic: Visio 2007 .dwg output for AutoCad 2008 LT  (Read 9884 times)

0 Members and 1 Guest are viewing this topic.

whirlpool1

  • Jr. Member
  • **
  • Posts: 14
  • Jetski_Ninja_and_Visio_Noob
Visio 2007 .dwg output for AutoCad 2008 LT
« on: April 11, 2012, 09:29:04 AM »
Hi all,

Im investigating some issues, whereby I need to save my Visio 2007 drawings and send them to a customer in .dwg format (for AutoCad).
The process of export is painless (Save As), but when the files are opened in AutoCad (2008 LT specifically), there are some deficiencies.
Oh no, I hear you all sigh... :)

My issues are really threefold;

1) Transparent and Graduated Fills
I have existing styles defined for certain types of object that change the Fill, Line and Text.  Some of these contain Transparent Fills and/or Graduated Fills.
When I open the file in AutoCad, after exporting, the fills are simply not there, which isn't a problem as I can 'switch' them back on with the Fillmode command in AutoCad (set to 1).
Anything that is a solid colour shows up just fine, but the transparent and graduated fills stay black.

Q1) I guess that the limitation is AutoCad (in that Transparent and Graduated fills are not supported, or is there anything I can do rather than amend all my standardised fills in Visio to compensate?

2) Connectors Lose Colour and Style Information
Also I notice that I have styles applied to connectors (cables in my case), which are colour coded, and it seems that all Connectors are bundled into one layer when exported to AutoCad and turned to a single line style and colour (black).

Q2) How can I get the connectors to keep their line type and colour in AutoCad?

3) Loss of images (such as PNG and JPG)
Lastly, If I use an image within my Visio file (say a PNG or a JPG), this disappears in the AutoCad conversion.

Q3)  How can I prevent this, and have the image (or at least a placholder/path/link/Xref) stay within the AutoCad file?

Many thanks in advance,
Whirlpool1
Build it and they will come...

whirlpool1

  • Jr. Member
  • **
  • Posts: 14
  • Jetski_Ninja_and_Visio_Noob
Re: Visio 2007 .dwg output for AutoCad 2008 LT
« Reply #1 on: April 11, 2012, 09:49:52 AM »
As a suggestion to part of this, if I made a copy of the Visio file I was exporting, I could run an add-on or macro that 'turned connectors into lines' before I did the export, this way I would save the original file with connectors intact (in case I had to modify it later).
Then when I exported the copied Visio file, the lines would retain their colour and style information.

Does anyone know of a tool or add-on that will change all 'connectors' in a file into 'lines' whilst still maintaining all the colour and style info of course?
Build it and they will come...

Paul Herber

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2947
    • Paul Herber's website
Re: Visio 2007 .dwg output for AutoCad 2008 LT
« Reply #2 on: April 12, 2012, 05:04:43 AM »
Please have a look at my Visio Utilities
http://www.sandrila.co.uk/visio-utilities/
It can do shape substitute. You will need to create a new stencil containing a line shape, just have the new stencil open when you do the substitute. I've just tried it, it seems to work.
Electronic and Electrical engineering, business and software stencils and applications for Visio -

https://www.paulherber.co.uk/

whirlpool1

  • Jr. Member
  • **
  • Posts: 14
  • Jetski_Ninja_and_Visio_Noob
Re: Visio 2007 .dwg output for AutoCad 2008 LT
« Reply #3 on: April 12, 2012, 07:05:35 AM »
Thanks Paul,  I'll try that...
Unfortunately, the zip file seems to be corrupted.  Ive tried it several times, and I get an Unexpected Enf of File... Im using WinRar...
Is it my end?
Build it and they will come...

Paul Herber

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2947
    • Paul Herber's website
Re: Visio 2007 .dwg output for AutoCad 2008 LT
« Reply #4 on: April 12, 2012, 07:16:02 AM »
Well, I've just downloaded it myself, it opens fine in WinZip and 7-zip. I don't have WinRar.
Electronic and Electrical engineering, business and software stencils and applications for Visio -

https://www.paulherber.co.uk/

whirlpool1

  • Jr. Member
  • **
  • Posts: 14
  • Jetski_Ninja_and_Visio_Noob
Re: Visio 2007 .dwg output for AutoCad 2008 LT
« Reply #5 on: April 12, 2012, 07:41:07 AM »
Weird, tried it from someone else's PC and it failed first time but worked the second :)
Playing with it now :)
Build it and they will come...

whirlpool1

  • Jr. Member
  • **
  • Posts: 14
  • Jetski_Ninja_and_Visio_Noob
Re: Visio 2007 .dwg output for AutoCad 2008 LT
« Reply #6 on: April 12, 2012, 08:34:31 AM »
Hi Paul,

I have tried playing with the utils (great stuff by the way), and might need a bit of advice to get this to work as I need it.

Essentially, I have a Visio drawing with a bunch of connectors glued between shapes with connection points (which represent cables between pieces of equipment).  The connectors have varying styles assigned to them dependant  upon which cable types they are, so for example;

CABLE_Video style assigned to the connector, will make the connector Blue and Line Pattern 1 (Solid),
CABLE_Data style assigned to the connector, will make the connector Red and Line Pattern 4 (Dash-dot),
CABLE_Alarm style assigned to the connector, will make the connector Pink and Line Pattern 1 (Solid)

I have also created a stencil which has each cable type drawn as a line (rather than a connector) with the correct style applied to it.

I need to change the connector to a line, while maintaining the style content, which I have already tested in AutoCad, and lines with the styles applied convert across fine.

In your utility, I presume I select the following options;

Shape(s) to replace = all Dynamic connector shapes
New shape name = (any one of the lines Ive drawn in the new stencil)

My question is, which Properties should I select to turn it into a line only?  line format?  When I do this, all my connectors disappear...
Any advice?

Thanks,
Glynn
Build it and they will come...

whirlpool1

  • Jr. Member
  • **
  • Posts: 14
  • Jetski_Ninja_and_Visio_Noob
Re: Visio 2007 .dwg output for AutoCad 2008 LT
« Reply #7 on: April 12, 2012, 09:29:07 AM »
Ive done some more investigations here...

The reason that AutoCad doesn't like connectors and maintaining the styles is due to the fact that connectors are on the 'Connectors' layer by default in Visio.
When exported to AutoCad, it bundles all things on the same layer together, and makes the the colour defaulted to ByLayer in AutoCad (and hence, black).

If you select the Visio drawing contents and format the layers for all objects so that they are not on any layers at all - when you export, the colour information then stays with the connectors, as it is not overridden by the layer AutoCad creates.

This way I dont need to do shape substitution, as Im okay with removing layer information from my cables.  Many thanks though Paul, as it has introduced me to your nice little utils package :)

I now have work arounds for all the issues except for the images not converting across...
Any takers? lol :)

Thanks,
Glynn
Build it and they will come...

Paul Herber

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2947
    • Paul Herber's website
Re: Visio 2007 .dwg output for AutoCad 2008 LT
« Reply #8 on: April 12, 2012, 10:20:13 AM »
Glad you've got your problem sorted, noy having AutoCAD I can't try it ouy here.
Hope you find the utilities useful, I'm trying to work out how to create a proper installer.
Electronic and Electrical engineering, business and software stencils and applications for Visio -

https://www.paulherber.co.uk/