Author Topic: Shapes 'Leaping' page away when connecting them to others  (Read 7839 times)

0 Members and 1 Guest are viewing this topic.

ben.shotbolt

  • Newbie
  • *
  • Posts: 2
Shapes 'Leaping' page away when connecting them to others
« on: October 13, 2011, 04:03:27 AM »
Hi all I'm a Newb' to the forum with a VERY ANNOYING PROBLEM

I'm a Technical Author with heavy involvement in documenting my company's networks. I'm drawing a lot of network diagrams which involves dropping and connecting lots of server shapes, Clouds, routers and many other types of object on to a page, often centred around the Ethernet pipe shape.

My Problem is when I have dozens of shapes I want to 'connect' to the Ethernet pipe shape (or the Cloud shape), I grab one of the Ethernet pipe's yellow diamond shaped connectors and drag it & dropit on to a server's connection point. Suddenly and without logical explanation, the Ethernet pipe shape quite litterally 'Leaps' 5 or 6 pages away (mormally off to a diagonal top right), showing the connection I created to the object, but this 'Leaping' happens constantly.

Folks, I am moderately well versed with Visio, enough to understand why this contstantly dogs me, if only I could find out why??I've attached a screen shot to demonstrate roughly what I mean.

Can any of you help please? This issie is costing me Lots of time dragging the 'Leaping' shape pages and pages back over to where it should be.

Thanks

« Last Edit: October 13, 2011, 04:06:46 AM by ben.shotbolt »

Paul Herber

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3301
    • Paul Herber's website
Re: Shapes 'Leaping' page away when connecting them to others
« Reply #1 on: October 13, 2011, 04:18:33 AM »
Page Setup -> Layout and Routing
clear "Move other shapes away on drop"
Electronic and Electrical engineering, business and software stencils and applications for Visio -

https://www.paulherber.co.uk/

ben.shotbolt

  • Newbie
  • *
  • Posts: 2
Re: Shapes 'Leaping' page away when connecting them to others
« Reply #2 on: October 13, 2011, 04:40:03 AM »
Thanks for your suggestion. I've chekced and that option is already unticked.

Do you think I may have discovered a bug in Visio 2010? Or are there any other suggestions?

Jumpy

  • Hero Member
  • *****
  • Posts: 1061
Re: Shapes 'Leaping' page away when connecting them to others
« Reply #3 on: October 13, 2011, 03:46:24 PM »
Maybe the shapes or connectors are placed too tight together and Visio forces a rerouting?
In Layout+Routing (?) you can define, how close connectors can be to each other.

bmccorkle

  • Newbie
  • *
  • Posts: 1
Re: Shapes 'Leaping' page away when connecting them to others
« Reply #4 on: February 19, 2013, 12:27:38 PM »
Did anyone fine a solution to this?  I recently installed Visio 2013 and the ethernet shape jumps almost everytime I try to connect it to another shape.  I made sure "Move other shapes away on drop" is unchecked.

wapperdude

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4449
  • Ideas Visio-lized into solutions
Re: Shapes 'Leaping' page away when connecting them to others
« Reply #5 on: February 19, 2013, 01:30:54 PM »
I don't have access to V2010 anymore, but, from what I remember it looks like you have Visio feature enabled that allows Visio add pages as needed.  I believe it's called Autosizing, it's on the Design Tab, and by default, it is on.  (Thanks Chris, your book to the rescue.)

Based on the png drawing that you attached, it looks like there isn't enough room to place the Ethernet pipe shape and have shape / shape spacing and connector/connector spacing.  So Visio "helps" you by increasing the drawing size automatically.  In my opinion, a particularly annoying feature.

So, try disabling that feature.  You may need to shift your existing shapes to make everything fit, or manually change the page size.

HTH
Wapperdude
Visio 2019 Pro