Shapes 'Leaping' page away when connecting them to others

Started by ben.shotbolt, October 13, 2011, 09:03:27 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi all I'm a Newb' to the forum with a VERY ANNOYING PROBLEM

I'm a Technical Author with heavy involvement in documenting my company's networks. I'm drawing a lot of network diagrams which involves dropping and connecting lots of server shapes, Clouds, routers and many other types of object on to a page, often centred around the Ethernet pipe shape.

My Problem is when I have dozens of shapes I want to 'connect' to the Ethernet pipe shape (or the Cloud shape), I grab one of the Ethernet pipe's yellow diamond shaped connectors and drag it & dropit on to a server's connection point. Suddenly and without logical explanation, the Ethernet pipe shape quite litterally 'Leaps' 5 or 6 pages away (mormally off to a diagonal top right), showing the connection I created to the object, but this 'Leaping' happens constantly.

Folks, I am moderately well versed with Visio, enough to understand why this contstantly dogs me, if only I could find out why??I've attached a screen shot to demonstrate roughly what I mean.

Can any of you help please? This issie is costing me Lots of time dragging the 'Leaping' shape pages and pages back over to where it should be.


Paul Herber

Page Setup -> Layout and Routing
clear "Move other shapes away on drop"
Electronic and Electrical engineering, business and software stencils for Visio -


Thanks for your suggestion. I've chekced and that option is already unticked.

Do you think I may have discovered a bug in Visio 2010? Or are there any other suggestions?


Maybe the shapes or connectors are placed too tight together and Visio forces a rerouting?
In Layout+Routing (?) you can define, how close connectors can be to each other.


Did anyone fine a solution to this?  I recently installed Visio 2013 and the ethernet shape jumps almost everytime I try to connect it to another shape.  I made sure "Move other shapes away on drop" is unchecked.


I don't have access to V2010 anymore, but, from what I remember it looks like you have Visio feature enabled that allows Visio add pages as needed.  I believe it's called Autosizing, it's on the Design Tab, and by default, it is on.  (Thanks Chris, your book to the rescue.)

Based on the png drawing that you attached, it looks like there isn't enough room to place the Ethernet pipe shape and have shape / shape spacing and connector/connector spacing.  So Visio "helps" you by increasing the drawing size automatically.  In my opinion, a particularly annoying feature.

So, try disabling that feature.  You may need to shift your existing shapes to make everything fit, or manually change the page size.

Visio 2019 Pro