Loss of shape view while dragging

Started by Soylent, July 30, 2008, 08:14:18 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.



This is the second time I've had this issue, and it seems to be related to some combination of presenting with Visio in LiveMeeting and/or altering presentation settings for a screen. Hoping someone has SOME kind of solution short of rebuilding my laptop.

Essentially, in some circumstances (which I have yet to nail down) LiveMeeting seems to lower the render settings (Text Quality and Display Options on View tab in Options dialog) presumably for faster display. These settings can subsequently be set back and normally this is fine. But twice, it has failed to restore the ability to see shapes while dragging. All that displays is a dashed box.

The first time, we tried a few things to correct this including rebuilding user profile and playing with registry settings... finally settling on installing Visio 2007 which fixed the issue. However since then, I have been furnished with a new laptop and after several months using Visio 2003 again with no issues, the problem surfaced again and installing 2007 has not helped this time. Both laptops in question were running WinXP.

Accessing as a different user does correct the problem, but I'm hoping to avoid messing with profile stuff if there is an easier fix. Anyone encountered this issue? TIA!

Visio Guy

Hi Soylent,

I'm suprised that Live Meeting would be smart enough to mess with Visio's display settings. They'd have to do that for so many different applications and so many different possible settings!

But I don't use Live Meeting that much, so what do I know.

I do know that when a shape is particularly complex, then you don't get a preview when dragging. Something to do with more than 25 sub-shapes grouped together. Also, if you start to drag, then pause for a second or two, sometimes the preview will get enough time to generate.

Can you verify that your preview is dead for very simple shapes like an ellipse or a circle?
For articles, tips and free content, see the Visio Guy Website at http://www.visguy.com
Get my Visio Book! Using Microsoft Visio 2010


Verified. I'm familiar with how complex shapes are handled - I'm talking *any* single shape. I particularly use visio for software GUI design wireframing, and even a single checkbox shape with text is dead. Simple text shape for that matter! It's not life-or-death but it sure is annoying...

I can attach a screenshot of the behaviour if it'll help.

And thanks for the speedy reply!


wth, attaching a screenshot now - here's me trying to move the text box with "End" - the dashed box is dragged but never renders the content of the shape. I can move and pause and it remains a dashed box. Hopefully you can tell that otherwise, the higher quality display settings are enabled.

Also re LiveMeeting - seriously, who woulda thought? But if you launch LM and share Visio, go to Options and you'll see that all of those View options are disabled. Sometimes, and I'm not sure under what conditions, it will also change them. Crazy.

Visio Guy

Ok, I found another setting...

Tools > Options > General Tab > "Enable live dynamics"

This is supposed to relate to showing how the shape reacts while you are stretching it or while you are moving control handles, not with dragging, but might be worth a try.

Maybe see if LM is messing with that one as well.

Also, I switched off the Text Quality and Display Options on my Visio 2007 Pro (U.S.) and this did NOT cause the drag-preview to stop functioning. I think we still don't have an accurate diagnosis.
For articles, tips and free content, see the Visio Guy Website at http://www.visguy.com
Get my Visio Book! Using Microsoft Visio 2010


I had tried playing a bit with that setting a little also, but hadn't checked if LM affects it.... you're right, it disables that setting as well while sharing visio. Still, can't make it fix me!

Actually I just went to a coworker's machine and played with every possible combination of these and other settings I could think of and could not manage to disable the drag view with any of them. So, yep, my assumption about the settings that LM changed was probably off but it definitely happened at the same time.

At a loss!


Went to run a preso today and Visio settings were once again hijacked - but I think it may have been by ThinkPad's presentation settings rather than by LiveMeeting. When I run LiveMeeting without a screen presentation, although it disables the *ability* to change the settings, it usually doesn't appear to *actually change* them. I thought it did in some circumstances (number of attendees, amount of shared content, etc.) but now I think it's either ThinkPad's "Presentation on Projector and Notebook" setting or some combination of that and LM.

I would love to test this hypothesis on someone else's laptop with working Visio but that might get me a sock in the face.  :)