Data Linking with database wizard not working in 2010

Started by trebortech, October 19, 2010, 10:19:58 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I've spent several days working on this and I was hoping someone else can confirm or deny my findings.

When I tried to use the Add-Ons-> Database Wizard to connect to SQL Server(Computer 1)  I would get the following error.

(Computer 2)
*********** ERROR MESSAGE BEGIN ************
Cannot set the database context information.
Additional error information: ODBC Error: S1009
[Microsoft][ODBC SQL Server Driver][SQL Server]Could not locate entry in sysdatabases for database 'tes'. No entry found with that name. Make sure the name is entered correctly.
*********** ERROR MESSAGE END ************

The database name is testdb and if I tried to connect via an access interface on an XP box to this database with ODBC it worked just fine.

So at this point I tried creating a new database with a shorter name, tried changing the user permissions on the database and still a no go!

I then decided to create two new machines. One XP box that would have Visio 2007 Prof (Computer 3) and the other with Visio 2010 (Computer 4).
I wanted to see if
------->  1. Was I doing the linking correctly since I've never done this before?
------->  2. Does x64 Windows 7 have anything to do with it?

-------> 1. Yes, with the Visio 2007 Prof XP install it worked great. No errors. (Computer 3)
-------> 2. No, the XP box installed with Visio 2010 had the same exact problem. (Computer 4)

So my conclusion and I would like for someone to please confirm or deny is that Visio 2010 (Premium in my install) has a ODBC problem.

Am I missing something or does anyone have an idea to what the problem could be?

Note: All hot fixes have been installed and updates.

Computer 1
Windows 2003 Standard Server
SQL Server 2003

Computer 2
Windows 7 x64
Visio 2010 - Prem

Computer 3
Visio 2007 - Prof

Computer 4
Visio 2010 - Prem



Maybe it is not Visio2010 but the 64 that has an ODBC problem?

I don't now much about it, but I recall a converstion (not Visio related) from some co-workers talking about problems one of them had, when accessing a certain DB with ODBC. When I remember correctly, the problem was, that he had a new Windows 7, 64 bit machine and the program he was using needed new 64bit ODBC driver? Don't now the details anymore, because I listened only with half an ear...sorry.


Given the error message pointing at a non-existent database it sounds like ODBC is at fault. I usually test this by attempting to link through the defined odbc connection using Access on the failing system.


I just had the same experience in Visio today. Did you manage to solve this issue?