Visio shapes shadow (cannot remove!), please help

Started by Jow Lim, October 27, 2010, 06:59:09 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Jow Lim

Hi,

I hope someone can help me with the following problem:

I've been trying to modify some of the shapes that come with Visio 2010. However some shapes appear to have an embedded shadow that appears to defy any attempt to remove or modify them. For example, from the "Computers and Monitors (Metric)" stencil, the "New iMac" shape. After making a copy of the Master Shape and deleting the keyboard, the shadow of the keyboard remains (please see attached image)

In this case I've identified the "shadow" is located in "Sheet.13" of the shape. Unfortunately I was not able to make modification to it. Can someone point me in the right direction?

Paul Herber

I've just tried this with the same shape, all parts removed except sheets6..13 as per your image and the keyboard completely disappears and there is no shadow left.
Electronic and Electrical engineering, business and software stencils for Visio -

https://www.paulherber.co.uk/

Jow Lim

Hi Paul,

I've managed to remove the keyboard shadow by deleting one of the "Geometry" from the ShapeSheet page. Do you know how to create this level form scratch? Thanks in advance.

Ps. The keyboard "shadow" (for for the monitor also) appears to be a level with a hidden drawing (outline?). When I selected a theme with shadow, these shadow will appear and follow how the shadow was setup. However, I just could't find where to unhide or edit the shape. Very fustrating! ???

Visio Guy

In order to make complicated shapes take a shadow properly, you need to create a union of all sub-shapes and send it to back. Then all of the other sub-shapes need to be locked against shadowing.

Now when a user applies a shadow to a shape, only that background "shadow mask" will get a shadow, and the shape will look correct. If shape designers didn't do this, every sub-shape in the group would get a shadow, and some of these would be on top of other sub-shapes. It would be a mess.

So you did the right thing: you found the "shadow shape", then deleted the Geometry section that represented the keyboard. Not easy, but right.

Visio should probably have some sort of setting that says: "apply shadow only to entire group, not sub-shapes".
For articles, tips and free content, see the Visio Guy Website at http://www.visguy.com
Get my Visio Book! Using Microsoft Visio 2010

Jow Lim

Hi Visio Guy,

Thanks a MILLION!

I did the union of a all shapes and send it to the background. Since I am modifying an existing shape, all the shape (images) I suppose have already been locked against showing shadow. Can you tell me how I can lock images against shadow?

Also, after placing the modified shape, typing on the shape (to enter information) resulted in the text directly over the shape (image). Can you tell me how I can setup the shape such that any text will be display below the shape image by default?


Jow Lim

Hi again,

Basically, after I've modified a shape (and moved the monitor the the center), the text by default appears over the shape itself (please see image). The original image had the default position (of the text) under the shape image. I've also noticed that if I clicked on the image, I can (still) select individual parts of the shape (e.g. in the attached image, I can still select the "screen" of the "monitor" shape! This is after I've saved the (new) Master Shape, and place an instance on a drawing!

Can someone tell me how I can achieve the following:
1. set the default position for any text typed under the shape, and
2. group all individual parts of the shapes and prevent selection (and deletion!) of individual part.

Thank you in advance.

Jow Lim

Hi,

Found the solutions to both problems. For the text position issue, just found Visio Guy's "Text to the Bottom of the Shape" article; should have look further first (sorry  :P)

For the part about preventing individual (parts) selection, that can be achieve by the following steps:

1. in the Master Shape (edit) page, select everything.
2. go to the "Developer" tab.
3. Select "Behavior"; in the "Shapr Design" group of the "Developer" tab.
4. Under "Group Behaviour", there is a drop-down field named "Selection:". Make sure this is set to "Group only"; by default it was set to "Group first".

:)