a full Drawing comes up on every startup

Started by wordracr, August 26, 2010, 03:30:14 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Every time I start Visio, I get a drawing1 (which is unsaved) and it's a sitemap of one of my sites that I've done recently, but I don't recall modifying any template or anything.

I searched my hard-drive for Visio files and didn't find anything like this, but hopefully one of you know where I might find the "default template" or what would be causing this.

It existed in Visio 2007 Standard and is also occurring now that I installed Visio 2010 Premium.  I did an uninstall and reinstall of 2010 and that didn't help.


Hi Wordracr,
I think to remember that some forum users here wanted to have exactly that behaviour!
Would be great if you could find out how you did it, so we could replicate it in controlled manner.

Paul Herber

It might be an old recovered file. Try saving it and close the document. Close and restart Visio.
Electronic and Electrical engineering, business and software stencils for Visio -



I tried the save thing (now for the 3rd time) and it does not help when I reopen.
Also trying to search for any files with AutoRecover in them.  Didn't find anything yet.

I renamed the only file in %appdata%\Microsoft\Visio\, a vsu file and it had no effect.

I dug through the registry too and found this key HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Visio\Application\ MyShapesPath
and I went to that dir.  I renamed the file, but no difference in visio behavior.
I'll check some other registery keys I find too.

any other settings dir you can point me to?

Visio Guy

Anything in your Startup path? Look here:

1. File > Options > Advanced
2. Scroll to the very bottom and click Paths
3. See if anything is typed into the last field
For articles, tips and free content, see the Visio Guy Website at http://www.visguy.com
Get my Visio Book! Using Microsoft Visio 2010


Nothing was in that textbox.
I did try setting something, relaunched visio and it tried to open things in that folder, but it still opened the drawing again too.

I've also tried uninstalling visio and deleting reg keys then reinstalling - no luck yet.

Any other ideas? I'm all ears


this problem still exists for me.  if you have any ideas besides reformat, i'd love to hear it :D

Paul Herber

Now, this may depend on what version of Visio you have.
Have a look at:
C:\Documents and Settings\<username>\Local Settings\Application Data\Microsoft\Visio
and delete (or rename) any file called contentxx.dat
Electronic and Electrical engineering, business and software stencils for Visio -



Hmmm...  %appdata% gets me to
I remember seeing Romaing before and I thought I'd checked Local too.
but if I go to the local folder C:\Users\username\AppData\Local\Microsoft\Visio,
I had an AutoRecover11.ini
that had the text:

I renamed the AutoRecover11.ini file and poof!  When I launch Visio - my 'problem' is gone :)
The file was just named "VSOB6E8".  If I changed it to vsd, I could open it on its own as a valid visio file.

So it was AutoRecover doing it.
Thanks so much.


And now to Yacines suggestion. Could this be replicated in a controlled manner? So that you could use this as a trick to start Visio always direct with the one right template? Would interest me, too.


Yes, that's why I gave so much detail  ;) about what's in the ini file and how the file is named (no ext)

Make sure autorecovery is turned on in visio and set it to save every minute.  You could even try loading up your docs you want with visio, change them ever so slightly, wait a minute, then terminate visio w/ Task Manager.  You'll probably have the exact setup.
Maybe your autorecover##.ini file is getting cleared out, but you could make a batch file to copy in a new one there and run the batch every hour with Windows Task Scheduler.