Problem with printing long pages

Started by Alicejane, March 30, 2010, 08:54:57 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


We use Visio to make indicative designs for websites. Our problem is that the pages are often longer than the background. We have problems printing these long pages. In Visio 2003 it was possible to individually scale the pages and print them. In the 2007 version this option is no longer available. Visio prints all the pages on the same scale and it is no longer possible to change the scale per page. Due to this, some pages are printed too small and thereby unreadable. There is also a problem with scaling; the pages are positioned in the middle in stead of the top of the page. It is not possible to correct them individually. Please does someone have a solution for this problem?


Hi Alice,
Some years ago, I took me about one week to get the correct printing settings for a solution, I implemented. And I don't touch them anymore. They're holy.
The printing options of Visio are not obvious. After having read your question, I played a little bit with some pages with different page settings and printing them with the PDF creator. There are so many different results, that it is difficult to answer your question easily. Big pages can both be scaled on one page or stretch over several ones.
I cannot agree with your statement that V2007 has no options to set different values to the pages. Correct me, if I'm wrong.
Can you post some examples of what you have and how you want it printed?


One known problem(?) of Visio 2007 is, that it prints drawings from the bottom up. I read that somewhere (here???).
That is different from what you would expect, working with other office products like Word or Excel and older Visio Versions didn't do that either, I was told.

So if you have a drawing that is longer/higher than one (paper)page you would expect a complete first page from top to nearly the bottom and the little bit that the drawing is to long at the top of the second page. What you get instead is the drawing from the bottom to nearly the top on the first page and the rest to the top at the bottom of the second page (with much white space above it).

There is no way to stop this, that I know about. It only may be possible to circumvent it somehow manually.


I use Visio 2007 and I can set the page setup and scale for each page separately. The settings under Page setup work for each separate page. They don't apply to all unless you want it to apply to all.


Oh. That was bad communication on my part. When in my previous post I talked about pages, I didn't mean Visio's pages but really printed paper pages.
I was talking about a drawing, with only one page that was longer than 1 DinA4 paper and was therefore printed on more than one paper page.