Author Topic: Visio 2010 - How do you turn fricking autosize off?!  (Read 22846 times)

0 Members and 1 Guest are viewing this topic.

David_H

  • Jr. Member
  • **
  • Posts: 39
Visio 2010 - How do you turn fricking autosize off?!
« on: February 16, 2010, 08:25:42 PM »
I do not have "autosize" selected on the Design ribbon.  I do not have "let Visio expand the page as needed" on the page setup dialog.  But F%*&ING Visio keeps endlessly decided to change the page size for me, how nice of them!  Ah, the joy of new features that are supposed to make our lives easier by making choices for us :).  Here is the scenario.  I want my page sized to 36" x 24".  Yes, I really do want that Visio, even though you think I don't!  So how do I stop it from endlessly taking me back to 12" x 9" or whatever other size visio thinks the drawing should be?

Thanks :-)!

Edit: I am having a really hard time believing this is normal behavior.  I think this is a bug of some type and Visio keeps resizing my pages when it should not be.
« Last Edit: February 16, 2010, 08:34:50 PM by David_H »

Paul Herber

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2746
    • Paul Herber's website
Re: Visio 2010 - How do you turn fricking autosize off?!
« Reply #1 on: February 16, 2010, 08:48:13 PM »
What is a typical event that causes the page to resize.
I've just created a 36" x 24" page and I'm dropping shapes on it and doing stuff and no resizing is happening.

Electronic and Electrical engineering, business and software stencils and applications for Visio -

http://www.paulherber.co.uk/

David_H

  • Jr. Member
  • **
  • Posts: 39
Re: Visio 2010 - How do you turn fricking autosize off?!
« Reply #2 on: February 17, 2010, 02:22:02 AM »
Thank Paul.  I have concluded it is some type of bug (and a VERY irritating one at that).  Basically it happens under several conditions, but I have figured out how to stop it.  The conditions are:

1. Inserting a CAD drawing
ALSO
2. Copying and pasting items onto a page from a different sized page.

There may be other conditions that cause it too but those two definitely do.

I am able to stop it from happening by creating a new page and dragging some shapes onto the page.  Once I have done that I can safely insert a CAD drawing or copy and paste items from other pages without Visio deciding to resize the page for me.

aledlund

  • Hero Member
  • *****
  • Posts: 1412
Re: Visio 2010 - How do you turn fricking autosize off?!
« Reply #3 on: February 17, 2010, 10:22:15 AM »
You turn it off on the design tab (autosize). It's also modifyable via code. I think the visio team talked to it on their blog
http://blogs.msdn.com/visio/
al

jsa

  • Newbie
  • *
  • Posts: 1
Re: Visio 2010 - How do you turn fricking autosize off?!
« Reply #4 on: September 30, 2010, 05:59:16 PM »
Every time I open one of the drawings I created before I upgraded to Visio 2010, objects on some pages are strewn all across the screen. Auto-Size is always on by default (there doesn't seem to be a way to change this -- sure, I can turn it off, but I want it OFF BY DEFAULT! Leave matters of preference to the user for cryning out loud! Have you not read any of the books in the gargantuan UX Canon? I'm sure Bill Buxton would let you peruse his library - just ask.) Sorry... I clearly have some unresolved anger when it comes to the UX of this and implementation of the Ribbon (specifally the mapping of terminology, location and features we all knew in the days of Menus vs. what we have in Ribbon).  ;)

Anyway... now that I think about it, I'm not sure there's a link between the objects getting dispersed (or text boxes getting squeezed) and the Auto-Size feature, but... this is the only thread I could find even remotely related to the issue.

Anyone got any ideas?  The clean-up involved (putting each object back where it was last time the file was saved in Visio 2007) in each file is a MAJOR PAIN, and is causing project delays.
« Last Edit: September 30, 2010, 06:07:09 PM by jsa »

cnayan

  • Newbie
  • *
  • Posts: 9
Re: Visio 2010 - How do you turn fricking autosize off?!
« Reply #5 on: September 10, 2014, 07:12:33 AM »
I have worked on a similar issue with AutoSize. What I have learnt is that this feature is by default ON for every new page you create in Visio 2010. This setting is saved in the page. So, if you turn it off for a page and save it, when you open the page next time, it will be turned off like you set it last time. [For pages saved by Visio 2007, since this feature was not there, the default status for Autosize is ON.]

That means, you have to turn it off for each page you create.
« Last Edit: September 10, 2014, 07:15:15 AM by cnayan »