Auto-numbering misaligning connector arrows (using Number Shapes Add-on)

Started by rsrikanth83, November 22, 2023, 10:02:11 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi all,
For an already built process flow, I am doing auto-numbering, but noticing that every time, the connector arrows are getting misaligned. Assuming this is becoz the shape number generated creates space in the shape, even if I choose the Hide Shape Number option.

Has anyone faced this issue? Please let me know if a workaround is available.

auto-numbering navigation that I use: View menu -> Add-ons -> Visio Extras -> Number Shapes

Attached the screenshots of how I am setting up auto-numbering and the misalgnment as well.

Thank you,


You can select every thing on your drawing and run the command "never reroute". That should prevent the connectors from misbehaving.
I am not sure if the command is available on the standard ribbons, you may need to add it by yourself. Right mouse click, add a cutom ribbon, search for the command and add it.
Alternatively use the "Tell me what to do" field in the head of Visio's main window.


Thank you for your response. this is very helpful.

Saves me and team a lot of irritation.


A follow-up question on this.

If in multiple process flows, if the connectors are already misaligned, is there a way to bring them back to the original alignment (without using the undo option)?

Kindly let me know.

Thank you!




Posssibly:  select 1 misaligned connector, right click, from menu set to straight.  Then select all remaining naughty connectors and press <F4>, to apply last command to each of them.

Then, select 1 connector, reset to normal.  Select all, <F4>.  Possibly some variant of this process.  Possibly a bit of code to automate.  Possibly this doesn't help.
Visio 2019 Pro


Thank you! though manual, the first option is definitely helpful and I tried it out.

Appreciate your inputs!