Visio Guy

Visio Discussions => Visio Online, Cloud & SharePoint Issues => Topic started by: jvince on April 21, 2020, 06:01:08 AM

Title: Background 'field dialog box' for page name doesn't work in SharePoint
Post by: jvince on April 21, 2020, 06:01:08 AM
Hi all, long time lurker first-time poster!

I've used Visio in quite a basic way for a while now, but now I'm trying to share my Visio file on SharePoint and having some issues.

I have about 50 processes in individual tabs, that have internal hyperlinks, which work correctly.

I have 3 background pages, which have a field dialogue box at the top which has the tab's name, (so "Page name")... I also have the page number and total pages at the bottom.

Every page in the Visio file has the appropriate background applied to it, and the dialogue boxes show the correct page name and number when displayed in Visio on the desktop. However, when I upload this Visio file to the SharePoint site, every page has the name of its background page at the top... and has 0/<the correct amount of pages> at the bottom.

More curious still, when I "save as PDF" from SharePoint, all of the headers start to work again, and the page numbers are all correct.

Is there a setting I'm missing, or something with the SharePoint that isn't set up correctly that means these fields aren't working when uploaded? I'm at a Loss. I tried saving as .VDW but that was even worse, and the central half of the heading was not rendered correctly.

Many thanks in advance

JV